katrinasvr
?>

Составить программу на паскале. дано натуральное число: а) найти количество четных цифр; б) верно ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.

Информатика

Ответы

vadimpopov88
Var a,b,c,c1,a1:integer;
begin
write('введите число => ');
readln(a);
write('введите число а => ');
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln('количество чётных цифр =>', c);
if (c1>2) then writeln('а встречается в числе больше двух раз');
end.
Serafim
1.клавиатура,мышь,сканер.микрофон
2.процессор
3.чтение книги,толковый словарь,заучения правила(нащет видеокассеты зависит какое видео)
4.Backspace
5.Рабочий стол
6.операционная система
7.На ПЗУ (не знаю что это постояная память или жесткий диск
8.происходит обработка, связанная с изменением формы информации, но не изменяющая ее содержания
9.Название приложения,кнопка "Свернуть,кнопка "Закрыть",панель инструментов, палітра,рабочая область
10.Жесткий диск,флешка,лазерный диск (для DVD) ,SD-карты
11.Квадрат зелённый
jardi

В среде программирования QuickBASIC используется оконная технология организации диалога, рассчитанная на использование в качестве устройств ввода клавиатуры и специального манипулятора мышь. Маркер курсора клавиатуры или мыши позиционируется в одном из окон и нажимается клавиша <ENTER> или соответствующая кнопка мыши для выполнения выбранного действия связанного с этим окном.

Рассмотрим подробнее технологию организации диалога с использованием клавиатуры. Для выбора какого либо пункта меню необходимо нажать клавишу <ALT> фон слова File изменится и среда ожидает выбора конкретного раздела меню. Управляя курсором клавишами стрелки выбрать нужный раздел, после этого необходимо нажать клавишу <ENTER>. Под выбранным пунктом меню появится подменю. Управляя курсором клавишами < стрелки > выбрать нужный раздела подменю ,после этого необходимо нажать клавишу <ENTER>. В случае необходимости отмены исполнения выбранного пункта меню достаточно нажать клавишу <ESC>.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на паскале. дано натуральное число: а) найти количество четных цифр; б) верно ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

polyakovaelena
Anatolevich667
klimenokvapeshop1408
Yurevna
alexanderpokrovskij6
Zhilinoe134
horizma609
mar1030
ibzaira
drozd228758
lenacari
seletan1
Ольга тимур
nelli-bi6
sanyaborisov910067