expo3217
?>

Дан числовой массив а, состоящий из n натуральных чисел. определите количество элементов массива, которые при делении на 7 остаток 1, 2 или 5.

Информатика

Ответы

agutty3
Const
N = 7;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
j:=0;
WriteLn('Введи массив A(N)');
For i:= 1 to N do
 Begin
 Read(A[i]);
 if (A[i] mod 7 =1)or(A[i] mod 7 =2)or(A[i] mod 7 =5) then j:=j+1
 End;
WriteLn(j)
End.
Bobkov

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!


begin

 var (m,n):=(3,ReadInteger('n ='));

 SeqGen(n-1,m,t->begin Result:=t+m; m+=1 end)

     .Aggregate(BigInteger(1),(p,q)->p*q).Println

end.

---------------------------

n = 5

2700

--------------------------

n = 92

2905717351708908985405643744987697767130796956644732769142761496541317116624931720391311988753812039943077115478561297954388733569194661753822436538090873756174074892748228397527408937781819534979620536526957830995968000000000000000000000000000000000000000000


Напишите программу pascal - 1*(1+2)*(1+2+3)*(1+2+3+4)*(1+2+3+)
puma802

C# не знаю. ответа вряд ли дождешься.

Если обладаешь минимальными знаниями в C# - переделаешь с C++.

#include <iostream>

const float PI = 3.14;//определите значение сами. Можно, конечно, брать более точное(double) из библиотек, но ограничусь этим.

int main()

{

   int  

       R,//радиус бОльшей окружности.

       r = 20,//радиус меньшей окружности.

       result;//площадь.

   std::cin >> R;

   std::cout << "радиус бОльшей окружности = " << R << std::endl;

   std::cout << "радиус меньшей окружности = " << r << std::endl;

   std::cout << "Площадь равна = " << PI*(R*R-r*r);

   

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан числовой массив а, состоящий из n натуральных чисел. определите количество элементов массива, которые при делении на 7 остаток 1, 2 или 5.
Ваше имя (никнейм)*
Email*
Комментарий*