saljagindima
?>

Написать программу на с++, которая для заданного натурального числа удаляет из записи числа все цифры, кратные минимальной цифре

Информатика

Ответы

marketing3
#include <iostream>

int minimal_digit(int n)
{
  const int base = 10;
  int min_digit = 0;
  while (n>0) {
    int digit = n%base;
    if (digit < min_digit)
        min_digit = digit;
    n /= base;
  }
  return min_digit;
}

int filter_digits(int n, int filter_by)
{
  const int base = 10;
  int pow_base = 1;
  int result = 0;
  
  if (filter_by == 0) {
    return n;
  }
  
  while (n>0) {
    int digit = n%base;
    if (digit % filter_by != 0) {
      result += digit * pow_base;
      pow_base *= base;
    }
    n /= base;
  }

  return result;
}

int main()
{
  int n;

  std::cout << "Введите число n: " << std::endl;
  std::cin >> n;
  
  int digit = minimal_digit(n);
  int result = filter_digits(n, digit);
  
  std::cout << "ответ: " << result << std::endl;

  return 0;
}
ibombenkova

x > 2

x < 2

Объяснение:

Операция И имеет приоритет перед операцией ИЛИ

((Х < 3) и (X < 2)) или ((X > 2) и (X > 0))

Между двумя выражениями стоит операция ИЛИ, которая означает, что хотя бы одно из выражений должно быть истинным, чтобы всё выражение было истинным.

Возьмём первое выражение:

(Х < 3) и (X < 2)

Тут мы видим операцию И, которая указывает на то, что оба значения должны быть истинными, чтобы всё выражение было истинно, т. е. в данном выражении значение X должно быть < 2, чтобы выражение было истинным

(1 < 3) и (1 < 2) - true [истина]

(0 < 3) и (0 < 2) - true [истина]

и т. д.

Возьмём второе выражение:

(X > 2) и (X > 0)

Тут мы видим операцию И, которая указывает на то, что оба значения должны быть истинными, чтобы всё выражение было истинно, т. е. в данном выражении значение X должно быть > 2, чтобы выражение было истинным

(3 > 2) и (3 > 0) - true [истина]

(4 > 2) и (4 > 0) - true [истина]

и т. д.

Вернемся к тому, что между выражениями стоит операция ИЛИ, т. е. должны выполняться или левая, или правая часть. Приходим к итогу, что:

x > 2x < 2
Для какого числа X истинно высказывание: (Х < 3) и (X < 2) или (X > 2) и (X > 0)?
Для какого числа X истинно высказывание: (Х < 3) и (X < 2) или (X > 2) и (X > 0)?
annanas08

begin

 var n: array of integer;

 setlength(n,11);

 writeln('Введите содержимое массива:');

 for var l:= 1 to n.high do read(n[l]);

 writeln('Наибольшее значение: ',n.max,' его номер: ',n.lastindexmax);

end.

begin

 var n:= ArrRandomInteger(10,1,99);

 writeln('Исходный массив: ',n);

 var A:=n[n.High];

 n[n.High]:=n[n.Low];

 n[n.Low]:=A;

 writeln('Полученный массив: ',n);

end.

begin

 var n:= ArrRandomInteger(24,1,99);

 writeln('Исходный массив: ',n);

 for var l:=n.Low+1 to n.High-1 do n[l]:=0;

 writeln('Полученный массив: ',n);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на с++, которая для заданного натурального числа удаляет из записи числа все цифры, кратные минимальной цифре
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dashkevich-76611
Adno1578
Узлиян Фурсов1488
ольга1801
Борисовна_Кашутина
игнатова_Сергей1228
boldireve617
zvezda-71
proplenkusale88
Demina-Khokhlov584
Kashtelyan Tamara847
evamining
info2990
Avdeeva Inga1505
ikhilovb76
▲