const
n = 10; //количество элементов массива
var
a: array [1..n] of real;
i: integer;
begin
for i:= 1 to n do
begin
writeln('Введите ', i, ' элемент массива');
readln(a[i]); //вводим очередной элемент массива
end;
write('Исходный массив: ');
for i:= 1 to n do
write(a[i], ' '); //Выводим исходный массив
writeln; //Перевод на новую строку
write('Полученный массив: ');
for i:= 1 to n do
begin
a[i]:= a[i] * a[n]; //элемент массива умножаем на последний элемент
write(a[i], ' '); //выводим полученный элемент массива
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Программирование . тема . на операторы switch/case. составьте программу , которая по введённому номеру цвета в радуге (1-7) выводит на экран название соответствующего цвета (1- красный, 2- если введено любое другое число , то программа должна выводить сообщение об ошибке .