rada8080
?>

№1 составить программу: с цикла for пощитать сумму всех трехзначных чисел кратных 4. №2 составить программу: с цикла whiie пошитать сумму чисел кратных 5 из диапозона от 500 до 1000

Информатика

Ответы

oniks-plus
Первая программа:
program qwer;
uses crt;
var sum,i:integer;
Begin
 sum := 0;
 for i := 100 to 999 do
 if i mod 4 = 0 then sum := sum + i;
 write(sum);
End.
Вторая программа:
program qwer;
uses crt;
var sum, i : integer;
Begin
 sum := 0;
 i := 500;
sum := 0;
while i <1001 do
begin
  if i mod 5 = 0 then sum := sum + i;
  i := i + 1;
end;
write(sum);
End.
grigoriev8
Все довольно просто, мог бы и сам прогнать через ide!) 
1) const a: array [1..6] of integer=(1, 7, 3,6,0,10);  тут ты инициализируешь массив которые включает 6 элементов такие как: (1, 7, 3,6,0,10)
2) после ты по циклу начинаешь складывать все элементы массива, которые описаны выше - for i:=1 to 6 do s:=s+a[i]; т.е. 1+7+3+6+0+10
3) далее ты делишь сумму на 6 и присваиваешь результат переменной sr - sr:=s/6;
4) после этого пытаешься вывести значение переменной sr - writeln(‘sr=’, sr); 

ответ будет 4.5, но твоя программа не выполниться, т.к. 4.5 это дробное число, а у тебя на переменную sr стоит тип integer, для того, чтобы программа отработала и вывело ответ, сделай тип переменной sr: real и тогда у тебя все получиться =)

Если есть вопросы, то пиши
Georgievna

Абай (Ибраги́м) Кунанба́ев[2] (каз. Абай Құнанбайұлы (инф.); 29 июля [10 августа] 1845, урочище Жидебай в Чингизтау — 23 июня [6 июля] 1904, там же) — казахский поэт, композитор, просветитель, мыслитель[4], общественный деятель, основоположник казахской письменной литературы и её первый классик, реформатор культуры в духе сближения с европейской культурой на основе просвещённого ислама.

Абай Кунанбаев

Имя при рождении

каз. Ибраһим Құнанбайұлы

Дата рождения

29 июля (10 августа) 1845[1]

Место рождения

ур. Жидебай, Бийский уезд, Томская губерния, Российская империя

Дата смерти

23 июня (6 июля) 1904[1] (58 лет)

Место смерти

Жидебай[d], Семипалатинский уезд, Российская империя

Гражданство

Российская Империя

Род деятельности

лингвист, поэт, переводчик, композитор.

Настоящее имя — Ибрагим, но прозвище Абай (каз. Абай «внимательный», «осторожный»), данное бабушкой Зере, закрепилось за ним на всю жизнь. Его племянник — также известный казахский поэт и философ Шакарим Кудайбердиев.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

№1 составить программу: с цикла for пощитать сумму всех трехзначных чисел кратных 4. №2 составить программу: с цикла whiie пошитать сумму чисел кратных 5 из диапозона от 500 до 1000
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

is926582086060
ivanandrieiev1984268
oksanashabanovadc3197
lavr74
osuvorova7979
Элизбарян
oksit
stailwomen31
madjk
Александр
helena-belozerova
s-food
olartamonov6
Банова_Елена431
varvara82193