nurtilekisakov
?>

1. составьте программу, которая будет находить, на сколько квадратов, можно разрезать данный прямоугольник, если от него каждый раз отрезается квадрат максимально большой площади. примечание: стороны квадратов выражены натуральными числами. формат входных данных: выходной файл output.txt содержит одно число-количество квадратов

Информатика

Ответы

s45983765471717
РЕШЕНИЕ ВО ВЛОЖЕНИИ.

ВСЕГО ДОБРОГО!
annapiskun1
Взвесить любые две монеты друг с другом:
1) Если весы в равновесии то взвесить одну из этих монет с любой из оставшихся
а) Если монета которую взвешивают второй раз весит больше, то фальшивая та которая легче и та, которую не взвешивали
b) Если монета которую взвешивают второй раз весит меньше, то она и та с которой взвешивали в первый раз фальшивые
2) Если одна из монет весит больше другой, то взвесить ее с любой из оставшихся:
a)Если весы в равновесии, то фальшивая та с которой взвешивали в первый раз и с которой не взвешивали
b) Если новая монета весит легче, то фальшивая она и та с которой не взвешивали
jardi
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var x:=-2.0;
  while x<=2 do begin
    Writeln('x=',x:4:1,' y=',x*x*x+12:6:3);
    x+=0.2
    end
end.

Результат выполнения программы:
x=-2.0 y= 4.000
x=-1.8 y= 6.168
x=-1.6 y= 7.904
x=-1.4 y= 9.256
x=-1.2 y=10.272
x=-1.0 y=11.000
x=-0.8 y=11.488
x=-0.6 y=11.784
x=-0.4 y=11.936
x=-0.2 y=11.992
x= 0.0 y=12.000
x= 0.2 y=12.008
x= 0.4 y=12.064
x= 0.6 y=12.216
x= 0.8 y=12.512
x= 1.0 y=13.000
x= 1.2 y=13.728
x= 1.4 y=14.744
x= 1.6 y=16.096
x= 1.8 y=17.832
x= 2.0 y=20.000

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу, которая будет находить, на сколько квадратов, можно разрезать данный прямоугольник, если от него каждый раз отрезается квадрат максимально большой площади. примечание: стороны квадратов выражены натуральными числами. формат входных данных: выходной файл output.txt содержит одно число-количество квадратов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gnsnodir5001
artbogema2016
Darialaza
mashumi2170
Donleksa2016
Kochereva-Sergei
Lvova_Aleksandr933
timsch12
Galliardt Sergeevna1284
lechic3
lovely138887
Анастасия Елена
kzhgutova
Veril8626
missbuhgalter2013