5
Объяснение:
а = 10 (присваиваем переменной a значение 10)
b = 5 (присваиваем переменной b значение 5)
c = 7 (присваиваем переменной c значение 7)
min = a (присваиваем переменной min значение переменной a, теперь min = 10)
if b < min then min = b (если переменная b меньше переменной min (а это так 5 < 10) то присваиваем min значение переменной b, теперь min = 5)
if c < min then min = c (если переменная c меньше переменной min (а это НЕ так 7 > 5) то присваиваем min значение переменной c, теперь переменная min остаётся без изменений min = 5)
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу поиска наибольшего из четырех чисел с использованием подпрограммы поиска наибольшего из трёх чисел. в интернете не могу найти(
int max(int a, int b){ return a > b ? a : b; }
System.out.println(max(20, max(123, max(1234, 47568568;
Проверка:
$ javac Main.java
47568568