Построить схему машинного алгоритма и составить Паскаль- программу решения задачи с оператора выбора Case по варианту условия, определяемому номером бригады (табл. 7.1). Необходимые значения селектора n для каждой из ветвей вычислять по формуле, приведенной в 4-й колонке таблицы.
Объяснение:
Построить схему машинного алгоритма и составить Паскаль- программу решения задачи с оператора выбора Case по варианту условия, определяемому номером бригады (табл. 7.1). Необходимые значения селектора n для каждой из ветвей вычислять по формуле, приведенной в 4-й колонке таблицы.
.
.
.
.
дпьащатш
Рассмотрим обычное десятичное число, например, число 5623. Интуитивно понятно, что означают все эти цифры: (5 * 1000) + (6 * 100) + (2 * 10) + (3 * 1). Так как в десятичной системе счисления всего 10 цифр, то каждое значение умножается на множитель 10 в степени n. Выражение, приведенное выше, можно записать следующим образом: (5 * 103) + (6 * 102) + (2 * 101) + (3 * 1).
Двоичные числа работают по аналогичной схеме, за исключением того, что в системе всего 2 числа (0 и 1) и множитель не 10, а 2. Так же как запятые (или пробелы) используются для улучшения читабельности больших десятичных чисел (например, 1, 427, 435), двоичные числа пишутся группами — в каждой по 4 цифры (например, 1101 0101).
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Задано трехзначное положительное целое число. есть ли среди его цифр 3? если есть, на каком месте стоит? написать программу на языке паскаль
var a,i:integer;
s:string;begin;
readln(a);
str(a,s);
if length(s)<>3 then exit;
if pos('3',s)=0 thenbegin;
writeln('Nowhere');
exit;
end;
for i:=1 to length(s) do
if s[i]='3' then writeln(i);
end.
Пример ввода:
123
Пример вывода:
3