zalev
?>

Создать синквейн к одному из этих слов компьютер сканер клавиатура принтер монитор флешка винчестер программа

Информатика

Ответы

ddobrov32133
Компьютер
Всезнающий, молчаливый
Развлекает поучает
В наше время без компьютера не обойтись
Друг
juliaipatova1739

Объяснение:

Никогда такое не решал, но попробую

На выходе F=1

Идем с конца

До него & (конъюнктор) - это логическое AND

По таблице истинности находим, что На выходе 1, только если на входе 1 и 1, значит А=1

Теперь идем от А. Сначала инверсия, получаем 0

Далее 0 AND B и мы должны получить 1. И тут у меня ломается мозг.

0 AND что угодно - получим 0, а если так, то и F=0 станет.

Вот и логическая бомба.

Решения не вижу у этой задачи, если F=1

Еще функцию надо

F=(A)AND((NOT(A))AND(B))

1=1AND1, значит A=1 и

(NOT(A))AND(B)=1

тогда B=1 и NOT(A)=1.

но NOT(A)=1 и А=1 не может быть. Мы пришли к противоречию.

Утерян "лучший ответ". Нашедшему вернуть.

Andreeva

#include <iostream>

int main() {

const int SIZE = 10;

bool isSence = false;

int sum = 0;

int count = 0;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 arr[i] = rand() % 20 - 10; // "рандомно" заполняем массив от -10 до 10

 std::cout << arr[i] << "\t"; // выводим массив в консоль

 if (arr[i] >= 0)

  isSence = true;

}

for (int i = 0; i < SIZE; i++)

{

 if ((isSence) && (arr[i] > 0))

  sum += arr[i]; //sum = sum + arr[i];

  count++;

}

if (isSence)

 std::cout << "\nсреднее арифметическое положительных чисел = " << double(sum) / count << std::endl; // явное приведение типов

else

 std::cout << "\nВ массиве нету положительных чисел или нету нулей и/или отрицательных чисел" << std::endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать синквейн к одному из этих слов компьютер сканер клавиатура принтер монитор флешка винчестер программа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

books
cmdkotelniki
elyashatdinova
Равилевич_Олеговна1496
составить программу к задаче ОЧЕНЬ
oledrag7
ckiras9
knigi21212
Nonstop788848
Стуканова УЧРЕЖДЕНИЕ1877
uksusoval617
aobuhta4
kuziv31
brendacepedam
kurmaleeva
sotrudnik3
▲