vkorz594
?>

Составить программу "вычисление площади прямоугольника , если заданы координаты 3-х его вершин"

Информатика

Ответы

abcd138191
Var x1,y1,z1,x2,y2,z2,x3,y3,z3,abx,aby,abz,acx,acy,acz,s,mx,my,mz,c:real;
begin;
readln(x1);
readln(y1);
readln(z1);
readln(x2);
readln(y2);
readln(z2);
readln(x3);
readln(y3);
readln(z3);
abx:=x2-x1;
acx:=x3-x1;
aby:=y2-y1;
acy:=y3-y1;
abz:=z2-z1;
acz:=z3-z1;
mx:=aby*acz-abz*acy;
my:=abz*acx-abx*acz;
mz:=abx*acy-aby*acx;
c:=sqrt(sqr(mx)+sqr(my)+sqr(mz));
s:=0.5*c;
writeln(s);
end.
Люблянова_Р.1777

То есть вы знаете, что такое filter, что такое лямбда-выражения, для чего нужен префикс " * ", но при этом не знаете, как считывать какие либо данные с клавиатуры?)))

Если вам нужно считывать слова по одному, вы можете воспользоваться генератором списков:

words = [input() for _ in range(N)] #где N - произвольная длина вводимого списка

Если вы хотите ввести все слова, которые нужно обработать, разом в одну строку, используйте строковый метод .split(sep) и вводите слова разделяя каким либо уникальным символом (обычно это просто пробел)

words = input().split(' ')

Если у вас есть сомнения по поводу вводимого текста, или в задании обговорено, что вводимый текст может быть хоть статьёй из газеты, используйте модули string и re, что бы удалить из текста всякую шелуху и уже потом с ним работать

import re

import string

rawInput = input()

CleanText = re.sub(r' +', ' ', re.sub(rf'[{string.punctuation}]|\n', '', rawInput)) #Это удалит из введённого текста повторяющиеся пробелы, знаки препинания и символы переноса строки

words = CleanText.split(' ')

gorbunova188

То есть вы знаете, что такое filter, что такое лямбда-выражения, для чего нужен префикс " * ", но при этом не знаете, как считывать какие либо данные с клавиатуры?)))

Если вам нужно считывать слова по одному, вы можете воспользоваться генератором списков:

words = [input() for _ in range(N)] #где N - произвольная длина вводимого списка

Если вы хотите ввести все слова, которые нужно обработать, разом в одну строку, используйте строковый метод .split(sep) и вводите слова разделяя каким либо уникальным символом (обычно это просто пробел)

words = input().split(' ')

Если у вас есть сомнения по поводу вводимого текста, или в задании обговорено, что вводимый текст может быть хоть статьёй из газеты, используйте модули string и re, что бы удалить из текста всякую шелуху и уже потом с ним работать

import re

import string

rawInput = input()

CleanText = re.sub(r' +', ' ', re.sub(rf'[{string.punctuation}]|\n', '', rawInput)) #Это удалит из введённого текста повторяющиеся пробелы, знаки препинания и символы переноса строки

words = CleanText.split(' ')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу "вычисление площади прямоугольника , если заданы координаты 3-х его вершин"
Ваше имя (никнейм)*
Email*
Комментарий*