hacker-xx1
?>

Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через k дней, начиная с первого января 2008 года. напомним, что это был вторник. язык : паскаль. целое число k (0 < = k < = 1000) пример: входа: | выхода: 0 | tuesday, 01.01 5 | sunday, 06.01

Информатика

Ответы

MN-Natusik80
// Я очень, невероятно не люблю изобретать велосипеды
//Поэтому воспользуемся уже встроенным типом DataTime
//Pascal ABC.NET Версия 2.2 Сборка 790
uses system;
var k:integer;
startSys:DateTime; //сабж
m,d:string;
begin;
readln(k);
startSys:=startSys.AddYears(2007); //добавляет года к старту, отсчёт от 1
startSys:=startSys.AddDays(k); //добавляет кол-во дней
//тип сам определяет високосный год или нет
writeln(startSys.DayOfWeek,', ',startSys.Day,'.',startSys.Month); //вывод
end.
slava-m-apt
2. Сжатие изображений с потерями и без потерь

В зависимости от типа сжатия данных, можно определить два четко отличимых формата: с потерями и без потерь качества изображения. Изображения с потерями качества – это те, что теряют определенный процент информации. Существуют различные методы, позволяющие регулировать количество потерянной информации. Очевидно, что чем больше информации теряется, тем меньше получается точность изображения. К сожалению, изображения без потери информации выглядят более качественно, но размер их будет довольно внушительным. Выбор изображений с потерей качества будет правильным решением для опубликации их в Интернете – так уменьшается скорость загрузки картинок. Как правило, большой размер изображения требует больше времени для загрузки. Люди не очень терпеливы, чтобы ждать загрузки “ленивых” сайтов. Долгая загрузка практически эквивалентна потере трафика, а это неприемлемо для большинства владельцев сайтов.

Но есть и хорошая новость. Существуют различные системы управления контентом, которые предлагают множество решений при работе с изображениями. Вы можете попробовать нашу CMS. Уверены, вы будете в восторге от бесконечных возможностей манипулирования изображениями. Шаблоны MotoCMS создаются с использованием только самых лучших фотографий и иллюстраций. Скриншоты ниже вам составить краткое представление о высоком качестве и оригинальности используемых изображений.
1. Растровое изображение против векторного

Растровые изображения состоят из мелких точек, которые называются пикселями. Средняя по величине картинка сформирована из миллионов пикселей. Благодаря множеству пикселей изображение приобретает четкость. Главный недостаток растровых изображений в том, что они очень большое. Все просто: в большом изображении каждый пиксель увеличен, а качество изображения уменьшается.

Векторное изображение может решить данную проблему: этот тип создается из линий и кривых. Чтобы объяснить, как это функционирует, нужно применять математические знания, но я, честно говоря, не готов сейчас вдаваться в такие подробности. И я уверен, вы тоже не заинтересованы в скучных математических выкладках. Важно то, что этот процесс обеспечивает полную свободу в изменении размеров изображений. К сожалению, векторные изображения затрудняют или вообще не позволяют использование некоторых эффектов.

Людмила Анна
Var
  a: array[1..10] of integer;
  i, max, imax, min, imin: integer;

begin
  Randomize;
  max := 0;min := 101;
  Write('Исходный массив:        ');
  for i := 1 to 10 do
  begin
    a[i] := random(100) + 1;
    Write(a[i], ' ');
  end;
  Writeln();
  For i:= 1 to 10 do begin
   if a[i] > max then
    begin
      max := a[i];
      imax := i;
    end;
    if a[i] < min then
    begin
      min := a[i];
      imin := i;
    end;
  end;
  swap(a[imax], a[imin]);
   Write('Преобразованный массив: ');
   For i:= 1 to 10 do
     Write(a[i], ' ');
   Writeln;
   Write('Я поменял местами ', imax, ' и ', imin, ' элементы');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через k дней, начиная с первого января 2008 года. напомним, что это был вторник. язык : паскаль. целое число k (0 < = k < = 1000) пример: входа: | выхода: 0 | tuesday, 01.01 5 | sunday, 06.01
Ваше имя (никнейм)*
Email*
Комментарий*