Дана строка, содержащая два слова, разделенных знаком нижнее подчеркивание.написать программу, меняющую нижнее подчеркивание на запятую и вставляющую поле запятой пробел, решить в паскале
Var s:string; k:integer; begin writeln('Введите строку'); readln(s); k:=POS('_',s); s:=COPY(s,1,k-1)+', '+COPY(s,k+1,length(s)-k); writeln(s); end.
mariapronina720126
24.10.2022
1) Это явно шифр замены. Мы знаем, что: А = Я, Н = С, Т = М, О = Р, М = Т, И = Ц, Х = Й, Л = У, Ь = Г, Е = Ъ, В = Э, Г = Ь, Й = Х. Этого достаточно, чтобы подставить буквы и получить НМЪПЯС = СТЕ*АН, очевидно, что это СТЕПАН. А если немного подумать, то можно догадаться, какой это шифр. Взяли алфавит и написали два раза - прямо и наоборот. Каждая буква из 1 алфавита заменяется на букву 2 алфавита. А = Я, Б = Ю, В = Э, Г = Ь, и так далее.
2) Про Виталия. Из 96 друзей 76 знают Павла и 56 знают Андрея. Значит, минимум 76+56-96 = 36 чел знают и Павла и Андрея. Про Павла. Из 162 друзей 96 знают Андрея и 76 знают Виталия. Минимум 96+76-162 = 10 знают и Андрея и Виталия. Про Андрея. Из 108 друзей 56 знают Виталия и 96 знают Павла. Минимум 56+96-108 = 44 знают и Виталия и Павла. Выбираем наибольшее из минимальных чисел. ответ: минимум 44 чел знакомы со всеми тремя парнями.
sinicin80
24.10.2022
// PascalABC.NET 3.0, сборка 1128 begin Writeln('Исходный массив'); var a:=ArrRandom(70,1,1000).Println(','); Writeln('Количество элементов, кратных 3: ', a.Where(x->x mod 3=0).Count) end.
Тестовое решение: Исходный массив 928,188,299,147,61,366,787,358,715,625,517,552,522,238,569,806,342,808,71,400,176,504,525,242,194,126,595,883,78,627,317,966,478,671,557,665,734,408,665,377,430,2,232,125,161,801,561,541,341,172,273,179,345,584,181,424,663,58,953,935,771,905,280,89,309,552,74,852,682,904 Количество элементов, кратных 3: 21
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Дана строка, содержащая два слова, разделенных знаком нижнее подчеркивание.написать программу, меняющую нижнее подчеркивание на запятую и вставляющую поле запятой пробел, решить в паскале
begin
writeln('Введите строку');
readln(s);
k:=POS('_',s);
s:=COPY(s,1,k-1)+', '+COPY(s,k+1,length(s)-k);
writeln(s);
end.