Bezzubova_Stepanov1355
?>

Даны катеты прямоугольного треугольника. найти его гипотенузу. составить программу.

Информатика

Ответы

yurievaalxndra55
Var a,b:real; begin write('Введите катеты: '); read(a,b); writeln; write('Гипотенуза = ',sqrt(sqr(a)+sqr(b)):0:2); end.
nzagrebin363
Каждому, кто пользовался электронной почтой, известен знак @ (по-русски его неофициально называют собакой). В английском языке этот знак называется at sign или commercial at ‘коммерческое at’.
До начала компьютерной эпохи он использовался в английском языке для обозначения цены: 7 widgets @ $2 each, то есть 7 штук по 2$. В английском языке в данном контерксте используется как раз предлог at. Именно в торговых документах.
Есть несколько гипотез относительно происхождения этого знака. Самая распространенная утверждает, что это сокращенное написание латинского предлога ad. Другая называет его сокращением греческого предлога aná ‘в размере, по’, употребляемого с числительными.
В Испании с XIV века известна мера арроба. Первоначально так назывался бочонок для вина, затем так стали называть меру жидкости и меру веса. В Кастилии она равнялась 11,5 кг, в Арагоне = 12,5 кг. Римский профессор Джорджио Стабиле обнаружил документ 1537 года, написанный флорентийским купцом. В нем упоминалась упоминалась «цена одной @ вина». Здесь знак @ мог обозначать слово amphora или arroba. Слово arroba сейчас используется в испанском языке для обозначения знака @ (см. ниже).
Помимо переписки по электронной почте и обозначения цены знак @ используется в некоторых языках программирования (Perl, PHP, Pascal). Есть у него и другие функции. Например, в испанском и итальянском языке этот знак иногда используется в неофициальной переписке по электронной почте, заменяя буквы о и а в окончаниях. Например, слово [email protected] используется вместо amigos ‘друзья’ и amigas ‘подруги’.
Fomin Korablev1781
Var c,i:integer;

function IntToBin2(Value: integer): string;
var  i: integer;
begin
Result:= '';
for i:= 0 to Trunc(Ln(Value)/Ln(2)) do
Result:= IntToStr((Value and (1 shl i) shr i))+Result;
end; 

begin;
for c:=41 to 69 do
writeln(c,'=',IntToBin2(c));
end.

Вывод:
41=101001
42=101010
43=101011
44=101100
45=101101
46=101110
47=101111
48=110000
49=110001
50=110010
51=110011
52=110100
53=110101
54=110110
55=110111
56=111000
57=111001
58=111010
59=111011
60=111100
61=111101
62=111110
63=111111
64=1000000
65=1000001
66=1000010
67=1000011
68=1000100
69=1000101

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны катеты прямоугольного треугольника. найти его гипотенузу. составить программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Светлана308
Zhilinoe134
gk230650
marysya60
fil-vasilij90
madjk
Алёна Геннадьевна98
impulsmc715
tanyatanyat
pechatlogo4
asi19776
vasinam
cometa94558
dg9792794674
Тариелович871