firsova5911
?>

Даны целые числа x, y, z. вычислить max(x+y+z, xyz) начертить блок-схему составить программу в паскале

Информатика

Ответы

Даниил247
Программа:
var x,y,z,max:integer;
 begin
write('x=');readln(x);
write('y=');readln(y);
write('z=');readln(z);
if x+y+z>x*y*z
  then max:=x+y+z
 else max:=x*y*z;
writeln('max=',max);
end.
Схема - в файле
Даны целые числа x,y,z. вычислить max(x+y+z, xyz) начертить блок-схему составить программу в паскале
nikdenly

Я комментарием пометил ошибку

type point=record

x,y:real;

end;

var a:array[1..3] of point;

i,j: integer;

z: point;

c: real;

begin

writeln('Координаты вершин');

readln(a[1].x,a[1].y,a[2].x,a[2].y,a[3].x,a[3].y);

//отсортируем по убыванию y

for i:=1 to 2 do

for j:=i+1 to 3 do

if a[i].y>a[j].y then

begin

z:=a[j];

a[j]:=a[i];

a[i]:=z;

end;

//выбираем первую точку

if a[2].x a[2].x then    // Ошибка, здесь ничего не сравнивается

begin

z:=a[3];

a[3]:=a[2];

a[2]:=z;

end;

for i:=1 to 3 do begin

c:=sqrt(a[i].x*a[i].x + a[i].y*a[i].y);

writeln ('Расстояние от начала координат',' ',c);

end;

readln

end.

Olga-Borisovna
На первый вопрос: 
1.Химические
2.Психофизические 
3.Физические
На второй вопрос:
ИКТ-технологии для информационной среды системы образования
На третий вопрос:
Санитарно-эпидемиологические правила и нормативы устанавливают санитарно-эпидемиологические требования к размещению, устройству, оборудованию, содержанию, противоэпидемическому режиму, профилактическим и противоэпидемическим мероприятиям, условиям труда персонала, организации питания пациентов и персонала медицинских организаций.
На четвертый вопрос:
Гигиенические нормативы — установленные исследованиями допустимые максимальные или минимальные количественные и (или) качественные значения показателя, характеризующего тот или иной фактор среды обитания с позиций его безопасности и (или) безвредности для человека.
На пятый вопрос:
технические требования это требования которые нужно использовать при работе с техникой , монитор даёт плохое влияние ( лучами) на глаза и мозг облучая их .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны целые числа x, y, z. вычислить max(x+y+z, xyz) начертить блок-схему составить программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*