3) = С1 / А1
Объяснение:
Зная значение ячеек первой строки
А1 = 1 В1 = 3 С1 = 2 D1 = 4
вычислим по известным формулам значения ячеек во второй строке:
В2 = А1 + В1 = 1 + 3 = 4
С2 = D1 / С1 = 4 / 2 = 2
D2 = В1 + А1 = 3 + 1 = 4
На диаграмме мы видим 2 больших сектора, которые равны между собой, и 2 маленьких сектора, которые тоже равны между собой.
Так как В2 = D2 = 4 (т.е это большие сектора), то А2 = С2 = 2 (т.е это маленькие сектора)
Проверим какие формулы в результате равны 2
1) = А1 + 2 = 1 + 2 = 3 - эта формула не подходит
2) = D1 - А1 = 4 - 1 = 3 - эта формула не подходит
3) = С1 / А1 = 2 / 1 = 2 - эта формула подходит
4) = А1 + D1 = 1 + 4 = 5 - эта формула не подходит
/*last_sent_end - индекс конца последнего найденного на данный момент предложения. Т.к. отсчет в C++ с 0, то начальное значение -1. Просматривается строка посимвольно. Встречен один из символов - счетчик m увеличивается, длина предложения вычисляется как разность текущего индекса и индекса конца предыдущей строки, и заносится в std::vector<int> arr_of_length. В last_sent_end сохраняется индекс найденного символа - индекс конца последней найденной строки. Случаи некорректного ввода не обработаны.*/
#include <iostream>
#include <vector>
#include <string>
int main()
{
int m = 0, last_sent_end = -1;
std::string str;
std::vector<int> arr_of_length;
std::cout << "Input string: ";
std::getline(std::cin, str);
for (int i = 0; i < static_cast<int>(str.length()); i++)
{
const char symb = str[i];
if (symb == '!' || symb == '?' || symb == '.')
{
m++;
arr_of_length.push_back(i - last_sent_end);
last_sent_end = i;
}
}
std::cout << "m = " << m << '\n';
for (int sent_length : arr_of_length)
{
std::cout << sent_length << " ";
}
return 0;
}
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, решающую следующую : дано трехзначное число. вывести число, полученное при перестановке крайних цифр исходно числа. , !
program chislo;
var N,c1,c2,c3:integer;
begin
readln(N);
c1:=N div 100; {цифра разряда сотен}
c2:=(N div 10) mod 10;
c3:=N mod 10;{цифра разряда единиц}
writeln(c3*100+c2*10+c1);
end.