vdnh451
?>

Pascal на карте координаты начала и конца строящегося прямолинейного участка шоссе обозначены как (x1; у1 ) и (x2; у2 карьер, откуда можно брать гравий для стройки, имеет координаты (х0; у0), причем х0 не равно х1 определите минимальное расстояние от строящегося участка шоссе до карьера.

Информатика

Ответы

bureiko
Type
  Point=record
    x,y:real
    end;

procedure GetPoint(c:char; var A:Point);
  var
    x,y:real;
begin
  Write('Введите координаты x и y точки ',c,': ');
  Read(x,y);
  A.x:=x; A.y:=y
end;

function DistPoint(A,B:Point):real;
begin
  DistPoint:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

var
  A,B,M:Point;
  d,p,ab,ma,mb:real;
begin
  GetPoint('A',A); GetPoint('B',B); GetPoint('M',M);
  ab:=DistPoint(A,B); ma:=DistPoint(M,A); mb:=DistPoint(M,B);
  if ma>=ab+mb then d:=mb
  else
    if mb>=ma+ab then d:=ma
    else begin
      p:=(ma+mb+ab)/2;
      d:=2*sqrt(p*(p-ab)*(p-ma)*(p-mb))/ab
    end;
  Writeln('Минимальное расстояние составляет ',d)
end.

Тестовое решение:
Введите координаты x и y точки A: -3 -5
Введите координаты x и y точки B: 2 5
Введите координаты x и y точки M: -3 4
Минимальное расстояние составляет 4.02492235949962
Olga1233

Алгоритм действий:

1. Вымыть руки теплой водой с мылом

2. Надеть перчатки и обработать их шариком со спиртом

3. Набрать лекарственное средство в шприц непосредственно из ампулы или через иглу, предварительно обработать ампулу шариком со спиртом.

4. Выпустить воздух из шприца

5. Положить шприц с лекарственным средством в стерильный лоток накрытый стерильной салфеткой

6. Взять 3 стерильных шарика (2 смоченных в спирте,1-сухой) и стерильную салфетку

7. Выпрямить руку пациента

8. Подложить клеенчатый валик под локтевой сгиб пациента

9. Наложить выше локтевого сгиба на 3-4 см жгут, концами вверх

10. Убедится, что пульс на лучевой артерии хорошо определяется

11. Попросить пациента несколько раз сжать и разжать кулак

12. Определить пальпаторно пунктируемую вену

13. Обработать область локтевого сгиба размером 10*10см стерильным спиртовым шариком в одном направлений

14. Вторым стерильным спиртовым шариком обработать область пунктируемой вены в том же направлений

15. Снять сухим шариком излишек спирта

16. Взять шприц и убедится, что в нем нет пузырьков воздуха

17. Зафиксировать пальцами левой руки пунктируемую вену ниже обработанной области, не касаясь обработанной поверхности

18. Пропунктировать вену одним из одномоментно или поэтапно)

19. Потянуть на себя поршень шприца, увидев появление крови, поймете, что вы попали в вену

20. Развязать свободной рукой жгут и попросить пациента разжать кулак.

Убедится еще раз, что игла не вышла из вены

21. Ввести лекарство, не меняя положения шприца, медленно, левой рукой, оставив в шприце 0,5 мл раствора

22. Извлечь иглу после введения лекарства быстрым движением

23. Прижать место пункции сухим стерильным шариком

24. Согнуть руку пациента в локтевом сгибе на 3-5 минут

25 Использованные шприц, иглу, шарики, перчатки выбросить в коробку безопасной утилизации (КБУ)

 

Полковников_Милана

1. Заповніть словничок.

Проекти для виконавців складаються у середовищі Скретч. Виконавці, образи, сцена – це  програмні об'єкти середовища  Скретч. У Скретч виконавців називають спрайтами. Усі  спрайти мають властивості: імя, положення на сцені, розміри,  колір костюма та інш. Кожна із цих властивостей має своє  значення. Переглянути значення властивостей цього об’єкта  можна в розділі інформація. Сцена має такі властивості:  480 на 360 кроків виконавця і тло Тло можна змінювати використавши кнопики на панелі інструментів.

2. Запишіть вставлення об’єкта.

Створити новий об'єкт можна кількома

- обрати готовий об’єкт із бібліотеки спрайтів;

- намалювати в графічному об’єкті;

- вставити з файла;

- сфотографувати камерою підключеною до комп’ютера.

Над об'єктами можна виконувати різні дії: дублювати, вилучати, зберегти, сховати. Під час виконання програмного проекту зі спрайтами можуть бути пов’язані події, опрацювання яких призведе до змінення значень властивостей об’єктів.  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal на карте координаты начала и конца строящегося прямолинейного участка шоссе обозначены как (x1; у1 ) и (x2; у2 карьер, откуда можно брать гравий для стройки, имеет координаты (х0; у0), причем х0 не равно х1 определите минимальное расстояние от строящегося участка шоссе до карьера.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bugaevnicky
missbuhgalter2013
kadrevproduction
irina611901
kryshtall2276
ryazantseva
Александрович686
mashere59
sashaleb88
Kozloff-ra20146795
Angelina1139
Tkachenko1050
losevev5619
Kondratchik Vladimir
Юлия1972