sjmurko
?>

Составить программу вычисления стоимости покупки с учётом скидки. скидка в 10% предоставляется, если сумма покупки больше 1000 рублей. ниже предоставлен рекомендуемый вид экрана во время работы с программой введите сумму покупки 1200 сумма покупки с учётом скидки 1080

Информатика

Ответы

Vladislav98
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (p,q):=(1,0);
  for var i:=1 to 1000 do begin
    var (flag,j,r):=(True,2,Round(Sqrt(i)));
    while flag and (j<=r) do
      if i mod j = 0 then flag:=false
      else j+=1;
    if flag then begin
      (p,q):=(q,i);
      if q-p=4 then Write('(',p,',',q,') ')
      end
    end
end.

Результат
(7,11) (13,17) (19,23) (37,41) (43,47) (67,71) (79,83) (97,101) (103,107) (109,113) (127,131) (163,167) (193,197) (223,227) (229,233) (277,281) (307,311) (313,317) (349,353) (379,383) (397,401) (439,443) (457,461) (463,467) (487,491) (499,503) (613,617) (643,647) (673,677) (739,743) (757,761) (769,773) (823,827) (853,857) (859,863) (877,881) (883,887) (907,911) (937,941) (967,971)
Annabill1987
Маркированные списки применяются при перечислении или выделении отдельных фрагментов текста. А нумерованные списки полезны в тех случаях, когда нужно определить порядок изложения.
Создать маркированный список можно двумя
1. В начале абзаца ввести звездочку или знак "больше", а затем нажать Tab или пробел.
2. Автоматический маркированный список создается так: во вкладке "Файл" выбрать "Параметры". В разделе "Правописание" выбрать "Параметры автозамены". Затем в разделе "Автоформат" установить флажки напротив стилей.
Чтобы создать нумерованный список необходимо:
Написать "1." и поставить пробел или нажать Tab.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления стоимости покупки с учётом скидки. скидка в 10% предоставляется, если сумма покупки больше 1000 рублей. ниже предоставлен рекомендуемый вид экрана во время работы с программой введите сумму покупки 1200 сумма покупки с учётом скидки 1080
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vuyakovleva
bestform
Lesnova_Kiseleva730
Andrei-Shchukin
Vitproficosmetics
Шаленко
fedoseevgleb
MIKhAILOVNAAnton
akarabut343
okutihamv
TSKaraulova
Aleksei368
Хачатурович978
Ladyby6224
avakarica