Сорокина
?>

Составьте программу( pascal), которая заполняет массив a (1..10) случайными целыми числами от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15

Информатика

Ответы

ambstroy
Var a:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
begin
a[i]:=rndom(20)+1;
write(a[i],' ')
end;
writeln;
for i:=1 to 10 do
if (a[i]>5) and (a[i]<15) then write(a[i],' ')
end.
AverinAA6077
Program program1;
var
a:array [1..10] of integer;
int:integer;
begin
for int:=1 to 10 do
begin
a[int]:=rndom(20)+1;
write(a[int],' ')
end;
writeln;
for int:=1 to 10 do
if (a[int]>5) and (a[int]<15) then write(a[int],' ')
end.
zakaz1

ДЗ для ВЕРЫ ВИКТОРОВНЫ:

Объяснение:

Var I, N, m: integer;

{Выводит таблицу квадратов до N числа}

Begin

Readln(N); //Что вводим в этой строке и зачем? Как можно подсказать пользователю, что ввести?  

{Вводим до какого числа нам нужно получить квадрат; Подсказать можно через WRITELN}

Writeln('Таблица квадратов чисел от 1 до N'); //Сколько раз выполняется этот оператор?

{Один раз}

For i:=1 to N do //Сколько раз выполнится цикл?

{N раз}

Begin //Зачем снова писать операторные скобки?

{Затем, что это цикл, который всегда обособляется и отделяет от остальных операторов}

m:=i*I;

Writeln(I,' ',m); //Как по-другому оставить пробелы между столбиками?

{Можно сделать так    -     Writeln(I:3,m:16);}

End;

End.

Ka-tja78
1. Не знаю. Вопрос точно правильно написан?
2. в.пиксель
3. а.красный, синий, зеленый
4. а.хранения информации о цвете каждого пикселя экрана монитора
5. г.программа для создания и редактирования рисунков
6. б.графических примитивов
7.б. растровой графики
8. а.электронное устройство для хранения двоичного кода изображения, выводимого на экран
9.  а.дисплейный процессор и видеопамять(немного есть сомнения)
10. в. bmp
11.Разрешающая сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер различить 300 точек.
Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр:
300dpi : 2,54 ≈ 118 точек/см.
Следовательно, размер изображения в точках составит
25*118 и 30*118 = 2950х3540
Общее количество точек изображения равно:
2950 * 3540 = 10 443 000.
Информационный объем файла равен:
3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 Кб ≈ 30 Мб
12.65536 означает, что на каждый пиксель отводится два байта. Итого имеем 1280*2КБ=2,5МБ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу( pascal), которая заполняет массив a (1..10) случайными целыми числами от 1 до 20 и выводит на экран элементы, значения которых больше 5 и меньше 15
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fokolimp
sakh2010kprf7
ruslanriad10
pak1998378
lidiya08083268
Gennadevna-Darya1216
AHO436
ver2bit
Mamikin
sttig
Рудаков Бахтовар
Владимир-Денисович1080
Алексеевич949
alexeytikhonov