Даны две квадратные матрицы а и в размером 3х3. требуется найти с=а х в. составить программу нахождения числа строк матрицы а(n, n), сумма элементов у которых отрицательна. pascal abc
1)var a:array[1..3,1..3] of integer; b:array[1..3,1..3] of integer; c:array[1..3,1..3] of integer; i,j:integer; begin; writeln('A array:'); for i:=1 to 3 do begin; writeln; for j:=1 to 3 do begin; a[i,j]:=random(10)-10; write(a[i,j]:4); end; end; writeln; writeln('B array:'); for i:=1 to 3 do begin; writeln; for j:=1 to 3 do begin; b[i,j]:=random(-10,10); write(b[i,j]:4); end; end; writeln; writeln('C array:'); for i:=1 to 3 do begin; writeln; for j:=1 to 3 do begin; c[i,j]:=a[i,j]*b[i,j]; write(c[i,j]:4); end; end; end. 2)var a:array[1..1000,1..1000] of integer; i,j,k,n,u:integer; begin; randomize; readln(n); writeln('A array:'); for i:=1 to n do begin; writeln; for j:=1 to n do begin; a[i,j]:=random(10)-10; write(a[i,j]:4); end; end; for i:=1 to n do begin; for j:=1 to n do u+=a[i,j]; if u<0 then inc(k); u:=0; end; writeln; write('Result:',k); end.
Neveselova
11.09.2022
Пусть Чертёжник стоит в точке (0,0). Выполняя программу, Чертёжник нарисует цифры 1-9 и 0, в таком виде, как они пишутся на почтовых конвертах (см. рисунок). В фигурных скобках - комментарии, они не выполняются.
использовать Чертежник алг Циферки нач {рисуем 1} поднять перо сместиться в точку (2, 1) опустить перо сместиться в точку (2, 3) сместиться в точку (1, 2) {рисуем 2} поднять перо сместиться в точку (3, 3) опустить перо сместиться в точку (4, 3) сместиться в точку (4, 2) сместиться в точку (3, 1) сместиться в точку (4, 1) {рисуем 3} поднять перо сместиться в точку (5, 3) опустить перо сместиться в точку (6, 3) сместиться в точку (5, 2) сместиться в точку (6, 2) сместиться в точку (5, 1) {рисуем 4} поднять перо сместиться в точку (7, 3) опустить перо сместиться в точку (7, 2) сместиться в точку (8, 2) поднять перо сместиться в точку (8, 3) опустить перо сместиться в точку (8, 1) {рисуем 5} поднять перо сместиться в точку (10, 3) опустить перо сместиться в точку (9, 3) сместиться в точку (9, 2) сместиться в точку (10, 2) сместиться в точку (10, 1) сместиться в точку (9, 1) {рисуем 6} поднять перо сместиться в точку (12, 3) опустить перо сместиться в точку (11, 2) сместиться в точку (11, 1) сместиться в точку (12, 1) сместиться в точку (12, 2) сместиться в точку (11, 2) {рисуем 7} поднять перо сместиться в точку (13, 3) опустить перо сместиться в точку (14, 3) сместиться в точку (13, 2) сместиться в точку (13, 1) {рисуем 8} поднять перо сместиться в точку (15, 3) опустить перо сместиться в точку (15, 1) сместиться в точку (16, 1) сместиться в точку (16, 3) сместиться в точку (15, 3) поднять перо сместиться в точку (15, 2) опустить перо сместиться в точку (16, 2) {рисуем 9} поднять перо сместиться в точку (17, 1) опустить перо сместиться в точку (18, 2) сместиться в точку (18, 3) сместиться в точку (17, 3) сместиться в точку (17, 2) сместиться в точку (18, 2) {рисуем 0} поднять перо сместиться в точку (19, 1) опустить перо сместиться в точку (19, 3) сместиться в точку (20, 3) сместиться в точку (20, 1) сместиться в точку (19, 1) {возвращаемся в начало} поднять перо сместиться в точку (0, 0) кон
а дальше составляй число
Evagg3856
11.09.2022
Я не трус, но я боюсь! (Бриллиантовая рука) Да нам, царям, молоко нужно выдавать за вредность! (Иван Васильевич меняет профессию) Этот нехороший человек предаст нас при первой же опасности! (Джентльмены удачи) Бамбардия! Киргуду! Шутка! (Кавказская пленница) Шурик, это же не наш метод! (Операция Ы и другие приключения Шурика) Восток – дело тонкое. (Белое солнце пустыни) Утром деньги – вечером стулья,вечером деньги – ночью стулья… (Двенадцать стульев) Он, конечно. Виноват, но он… не виноват… (Берегись автомобиля)
Бриллиантовая рука - это не совсем верный ответ. В "Бриллиантовой руке" эта фраза тоже есть. Но впервые она появилась в фильме "Полосатый рейс"
b:array[1..3,1..3] of integer;
c:array[1..3,1..3] of integer;
i,j:integer;
begin;
writeln('A array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
a[i,j]:=random(10)-10;
write(a[i,j]:4);
end;
end;
writeln;
writeln('B array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
b[i,j]:=random(-10,10);
write(b[i,j]:4);
end;
end;
writeln;
writeln('C array:');
for i:=1 to 3 do
begin;
writeln;
for j:=1 to 3 do
begin;
c[i,j]:=a[i,j]*b[i,j];
write(c[i,j]:4);
end;
end;
end.
2)var a:array[1..1000,1..1000] of integer;
i,j,k,n,u:integer;
begin;
randomize;
readln(n);
writeln('A array:');
for i:=1 to n do begin;
writeln;
for j:=1 to n do
begin;
a[i,j]:=random(10)-10;
write(a[i,j]:4);
end;
end;
for i:=1 to n do begin;
for j:=1 to n do
u+=a[i,j];
if u<0 then inc(k);
u:=0;
end;
writeln;
write('Result:',k);
end.