Сулейманова
?>

1)как блок-схемой и на алгоритмическом языке представляется команда с предусловием? 2)как программируется цикл с предусловием на паскале? 3)почему алгоритм вычисления n! должен быть циклическим? 4)из каких этапов состоит работа программиста по решению на компьютере? 5)что такое формализация ? 6)что такое отладка программы ? что называется тестом?

Информатика

Ответы

boykovandrew6663

1. ромб, только стрелка вниз если условие сохраняется, стрелка в права, если условие нарушено, и слева приход при следующем цикле. (или наоборот) см рисунок

2. while i <= n do begin
        write ('(*) ');
        i := i + 1
    end;

3. потому что необходимо перебрать всезначения от 1 до N

4. постановка задачи;математическая формализация; построение алгоритма; составление программы на языке программирования; отлад­ка и тестирование программы; проведение расчетов и анализ полученных результатов.

5. описательная информационная модель записывается с какого-либо формального языка

6. отладка это испытание с исправлением ошибок, тест это окончательный прогон с конкретным значением данных для которых известен результат.


1)как блок-схемой и на алгоритмическом языке представляется команда с предусловием? 2)как программир
Kotvitskii

385

Объяснение:

Т.к. n = 10, то цикл выполниться 10 раз

количество повторов цикла = конечное значение - начальное значение + 1

конечное значение n (n = 10)

начальное значение 1 (для i от 1)

количество повторов цикла = 10 - 1 + 1 = 10

Значит действия в цикле (S = S + i * i) будет выполнено 10 раз, при этом i будет последовательно рана 1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Так как первоначально S = 0, запишем

S = 1 * 1 + 2 * 2 + 3 * 3 + 4 * 4 + 5 * 5 + 6 * 6 + 7 * 7 + 8 * 8 + 9 * 9 + 10 * 10 = 1 + 4 + 9 + 16 + 25 + 36 + 49 + 64 + 81 + 100 = 50 + 40 + 90 + 80 + 125 = 260 + 125 = 385

muz-cd

Объяснение:

А1)Что такое файл? *

1)программа (программы), с которых на компьютере выполняются конкретные задания

А2)Для чего используется клавиша Tab (Tabulation) компьютерной клавиатуры?

Выберите несколько вариантов ответа.

3)переход по каким-либо параметрам

А3)Расширение исполняемых файлов? *

1)avi

2)mp3

3)exe

А4)Выберите правильный порядок отправления электронного письма с вложением папки. *

1-написать адрес получателя.

2-заархивировать папку.

3-отправить.

4-написать тему письмя.

5-прикрепить архив папки.

.2, 1, 4, 5, 3

А5)Выберете расширения аудио файлов *

Выберите несколько вариантов ответа

1)wav

3)mp3

4)mid

А6)Укажите расширение файла Информатика.docx? *

2)Информатика.docx

А7)С какой программы из пакета MS Office можно создавать текстовые документы? *

2)MS Word

А8)Какой вид программы Калькулятор используется для перевода между сиcтемами счисления? *

3)Программист

А9)Клавиша, фиксирующая смену регистра букв со строчных на прописные? *

1)Caps Lock

А9)Какое действие нельзя выполнить с группой файлов? *

4)переименовать

А10)Нажав на какую клавишу можно включить/выключить цифровую клавиатуру? *

4)Num Losk

А11)Операционной системой НЕ является: *

1)Linux

2)Android

3)Windows Mobile

А12)Выберете правильную последовательность добавления таблицы *

1-нажать ок

2-указать число строк и число столбцов

3-выберите пункт «Вставить таблицу...»

4-перейти во вкладку «Вставка»

5-вставить на иконку «Таблица»

4, 5, 3, 2, 1

А13)Когда нажата эта клавиша, вводимый пользователем текст, будет заменять уже напечатанное ранее? *

1)Tab

А14)Файл, сохраненный в версии MS Word 97 – 2003, открывается в любой из версий MS Word? *

1)Верно

А15)Нажав на какую клавишу можно сделать снимок экрана? *

1)Print Screen

А16)Графические файлы могут иметь расширения … *

1)bmp

5)jpg

6)gif

А17)Расширение видео файлов … *

Выберите несколько верных ответов

2)mov

3)mp4

4)avi

А18)Имя файла состоит из … *

3)имени и расширения

А19)Какие действия можно выполнить с файлом? *

1)копировать

2)создать

4)переименовать

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)как блок-схемой и на алгоритмическом языке представляется команда с предусловием? 2)как программируется цикл с предусловием на паскале? 3)почему алгоритм вычисления n! должен быть циклическим? 4)из каких этапов состоит работа программиста по решению на компьютере? 5)что такое формализация ? 6)что такое отладка программы ? что называется тестом?
Ваше имя (никнейм)*
Email*
Комментарий*
▲