Сергей_Евгеньевич1255
?>

Напишите программу, определяющую, сколько в классе людей с самым высоким ростом (естественно, у них у всех он технические условия входные данные – количество n учеников в классе (15≤n≤40) и значения роста каждого ученика (наименьший рост равен 160, наибольший – 190 эти данные можно ввести с клавиатуры или прочитать их входного файла maxheight.dat, где в первой строке записано значение n, во второй – разделённые пробелами значения роста учеников. результат – количество учеников наибольшего роста – вывести на экран монитора или в выходной файл maxheight.sol.

Информатика

Ответы

dawlatowajana
Программа, пример файла с данными и результат - в прилагаемом файле
ganul

Пример на продукте - бананы

program v1;

var m,n,sum,t:integer;

st1:string[10];

 begin

   sum:=0; t:=0;

   writeln('Здравствуйте');

   writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');

   writeln('Сколько купите бананов '); readln(n);

  writeln('Введите цвет бананов '); readln(st1);

   if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;

   if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей')  then sum:=2500*n;

   if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный')  then sum:=3700*n;

   writeln('Сумма покупки ', sum);

   writeln('Введите сумму'); readln(m);

   t:=m-sum;

   writeln('Возьмите сдачу ',t);

   writeln('Всего доброго, приходите еще');

 end.


Дорогие программисты по информатике! Напишите программу по этим алгоритмам умоляю
membuksdk
Const n=20;
var a:array[1..n]of integer;
i,b,k,c,f,g,h:integer;
begin
for i:=1 to n do a[i]:=Random(70)-20;
for i:=1 to n do
write(a[i],' ');
writeln;
for i:=1 to n do begin
if (a[i] mod 5 = 0) and (a[i] mod 10<>0) or (a[i]=50) then begin
b:=i;
for b:=i to (n-1) do
a[i]:=a[i+1];
end; end;
for i:=1 to n do
write(a[i],' ');
write('введите к ');
read(k);
for i:=1 to n do begin
if a[i] mod i = 0 then begin
c:=i;
for i:=n downto c+1 do begin
a[i]:=a[i-1];
a[c+1]:=k;
end;end;end;
for i:=1 to n do
write(a[i],' ');
writeln;
f:=0; g:=0;
for i:=n downto 1 do begin
if (a[i]>0) then f:=i;
end;
if a[f]=0 then write('нет положительных ');
for i:=n downto 1 do begin
if (a[i]<0) then g:=i;
end;
if (a[g]=0) then write('нет отрицательных ');
if (a[f]<>0) and (a[g]<>0) then begin
h:=a[f]; a[f]:=a[g]; a[g]:=h; end;
for i:=1 to n do
write(a[i],' ');
writeln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, определяющую, сколько в классе людей с самым высоким ростом (естественно, у них у всех он технические условия входные данные – количество n учеников в классе (15≤n≤40) и значения роста каждого ученика (наименьший рост равен 160, наибольший – 190 эти данные можно ввести с клавиатуры или прочитать их входного файла maxheight.dat, где в первой строке записано значение n, во второй – разделённые пробелами значения роста учеников. результат – количество учеников наибольшего роста – вывести на экран монитора или в выходной файл maxheight.sol.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tkozina
fomindmity1
Advantage9111
dlydesertov1
Alexander2035
Stefanidi_Semeikina1896
aetolstih
hvostna23
Диана-Николаевна377
Некрасова-И
pokupatel688
nsn-2012
SaraevaTretyakov1941
Андреевна
Aleksandrovna Kolesnik1764
▲