sdy19576216
?>

Дано натуральное число. найти сумму его делителей, не кратных 3. нужно написать программу в паскале через div и mod. !

Информатика

Ответы

kristina
Программа считает 1 и само число(Если оно не кратно 3) за делители
program n1;
  uses crt;
var
  i,x,s:integer;
begin
writeln('Введите число'); readln(x);
s:=0;
for i:=1 to x do
  if (i mod 3<>0) then s:=s+i;
writeln(s);
end.
chuykin

Program zadacha;

Var x,y,z,ans:Int64;

Begin

ReadLn(x,y,z);

If (x>0) and (y>0) and (z>0) then Inc(ans);

If (ans=0) then WriteLn('Такой треугольник построить нельзя') else begin

     Write('Такой треугольник можно построить');

     If(x=y) xor (x=z) xor (y=z) then Write(', он будет равнобедренным') else

     If(x=y) and (x=z) and (z=y) then Write(', он будет равносторонним')else

     If(x=y) xor (x=z) xor (y=z) then Write(', он будет равнобедренным');

     If (sqr(x)+sqr(y)=sqr(z)) or (sqr(y)+sqr(z)=sqr(x)) or (sqr(z)+sqr(x)=sqr(y)) then

write(', он будет прямоугольным.')  else

     If(sqrt(sqr(x)+sqr(y))>z) xor (sqrt(sqr(z)+sqr(y))>x) xor (sqrt(sqr(x)+sqr(z))>y) then Write(', он будет остроугольным.')

else write(', он будет тупоугольгым.');

end;

End.

 

ps: не забудь пометить как лучшее решение

 

 

Елена

Правило получения числа из функции Random(X):  

    0 <= RandomNum < X

1)

  От 1 до 10 – Random(10)+1

  От -10 до 10 – Random(21)-10

  От 50 до 100 – Random(51)+50

2)

  Y:=10+Random(5)

  Random(5):

       Левая граница = 0

       Правая граница = 4

  Отсюда, Y ∈ [10; 14].

3)

// PascalABC.NET

// Версия 3.4.2, сборка 1956 (01/30/19)

var

 arr: array[0..99] of integer;

 p, n: integer;

begin

 (p, n) := (0, 0);

 for var i := 0 to 99 do

 begin

   arr[i] := Random(41) - 20;

   if (arr[i] > 0) then inc(p)

   else if (arr[i] < 0) then inc(n);

 end;

 Println('Positive:', p);

 Println('Negative:', n);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число. найти сумму его делителей, не кратных 3. нужно написать программу в паскале через div и mod. !
Ваше имя (никнейм)*
Email*
Комментарий*