obelov
?>

14. напишите программу нахождения факториала числа n! , где 0 n! = 1*2*3*…*(n-1)*n

Информатика

Ответы

chapaevval
Var i,n,S:integer;
begin
Readln(n);
S:=1;
For i:=1 to N do
S:=S*i;
Writeln(S);
end.
Skvik71
Воспользуемся расширенной записью шестнадцатиричного числа в десятичной системе счисления. Тогда
3(a*16²+b*16+c)=b*16²+c*16+a;
767a=208b+13c; 59a=16b+c → a=(16b+c)/59  (1)
Здесь a,b,c - шестнадцатиричные цифры, имеющие десятичный эквивалент от 0 до 15.
Наложим ограничения. a и b не могут быть нулевыми, поскольку с них начинаются числа, а с может быть и нулем. При b=15 и c=15 значение a по формуле (1) не может быть больше (16*15+15)/59, что в целых числах дает 4.
Следовательно, нам надо подобрать такие b и c, чтобы a принимало значения от 1 до 4. Будем подставлять эти значения в (1).
1) При а=1 получаем (16b+c)/59=1 → 16b+c=59.
b=59/16=3 (нацело), c=59-16*3=11. Искомое число 13B₁₆
2) При а=2 получаем (16b+c)/59=2 → 16b+c=118.
b=118/16=7 (нацело), с=118-16*7=6. Искомое число 276₁₆

Аналогичным образом находим два остальных числа: 3B1₁₆ и 4EC₁₆

Замечание. Фактически, мы получаем числа 59х1, 59х2, 59х3, 59х4 и переводим их в шестнадцатиричную систему счисления, поскольку в формуле (1) в скобках записано представление расширенное представление шестнадцатиричного числа.
praskovya17
Чтобы это узнать нам потребуется разобрать это на примере.
допустим у нас есть изображение размером 1024х1024 пикселя.
чтобы определить объем занимаемой памяти при наличии на нем 65 536 цветов для начала нужно выяснить сколькими битами кодировать один пиксель.  65 536 = 2^16 => один пиксель кодируется 16 битами. 
значит объем памяти изображения будет составлять:
1024*1024*16= 16 777 216 бит.
теперь вычислим объем памяти при  наличии 16 цветов на изображении.
16=2^4 =>
1024*1024*4=4 194 304
теперь чтобы определить во сколько раз уменьшился объем памяти изображения мы выполняем следующее действие:
16 777 216 : 4 194 304 = 4
т е объем памяти изображения уменьшился в 4 раза.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

14. напишите программу нахождения факториала числа n! , где 0 n! = 1*2*3*…*(n-1)*n
Ваше имя (никнейм)*
Email*
Комментарий*