ktv665
?>

Дано натуральное число. верно ли, что количество его цифр есть четное число, а само число не превышает b ? написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean

Информатика

Ответы

tenvalerij
Var i,n,k,b: integer;
begin
  write(' b = ');  readln(b);
  write(' n = ');  readln(n);
  i:=n;  k:=0;
  while i>0 do
   begin
    i:=i div 10;    k:=k+1;
  end;
  if n<=b then writeln('число n не превышает ',b)
  else writeln('число n больше ',b);
  if (k mod 2) = 0 then writeln('число цифр = ',k,' - четное')
  else writeln('число цифр ',k,' - нечетное');
end.
s777tver109

text = "Программа! "  # Переменная text Содержит строку "Программа! "

print(text [0:10])  # Индексирование каждого символа строки. [:] - Это срез. [0:10] - Вывести 10 символов - Целая строка, но только без пробела в конце строки, тк заданная команда выводит все символы строки (Если было бы [0:11] - то пробел конечно же был бы включен)

print(text [0:4])  # Вывести символы от индекса 0 - Это символ П, до индекса 4 - Это символ Р. Результат: Прог

print(text [-2])  # Отрицательное значение, обычно применяется для того, чтобы взять что-либо с конца строки, списка и т.п..

print(text [::3])  # Вывести каждый символ с чередованием 3 символа. Так скажем... Перешагнуть 2 символа, и уже 3й распечатать

Seropyan-Elena1944

проверки требуют 58 правок.

Три зако́на роботехники в научной фантастике — обязательные правила поведения для роботов, впервые сформулированные Айзеком Азимовым в рассказе «Хоровод» (1942).

Айзек Азимов, 1965

Законы гласят:

Робот не может причинить вред человеку или своим бездействием допустить, чтобы человеку был причинён вред.

Робот должен повиноваться всем приказам, которые даёт человек, кроме тех случаев, когда эти приказы противоречат Первому Закону.

Робот должен заботиться о своей безопасности в той мере, в которой это не противоречит Первому или Второму Законам.

Оригинальный текст (англ.)

A robot may not injure a human being or, through inaction, allow a human being to come to harm.

A robot must obey orders given it by human beings except where such orders would conflict with the First Law.

A robot must protect its own existence as long as such protection does not conflict with the First or Second Law.

Трём Законам, а также возможным причинам и следствиям их нарушения, посвящён цикл рассказов Азимова о роботах. В некоторых из них, наоборот, рассматриваются непредвиденные последствия соблюдения роботами Трёх Законов (например, «Зеркальное отражение»).

В одном из рассказов цикла персонаж Азимова приходит к заключению об этической основе Трёх Законов: «…если хорошенько подумать, Три Закона роботехники совпадают с основными принципами большинства этических систем, существующих на Земле… попросту говоря, если Байерли исполняет все Законы роботехники, он — или робот, или очень воспитанный человек»[1].

В 1986 году в романе «Роботы и Империя» (англ. Robots and Empire) Азимов предложил Нулевой Закон:

0. Робот не может причинить вред человечеству или своим бездействием допустить, чтобы человечеству был причинён вред.

Оригинальный текст (англ.)

0. A robot may not harm humanity, or, by inaction, allow humanity to come to harm.

Три закона роботехники — объединяющая тема для всей фантастики Азимова, включая не только цикл о роботах, но и некоторые другие произведения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число. верно ли, что количество его цифр есть четное число, а само число не превышает b ? написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annatarabaeva863
myatadinamo
evainvest1
eleniloy26
Elenazhukovafashion7
skalegin68
NikonA83
ski89439
olyavoznyak
kolgatin69
gre4ka2004
Irinalobanowa
sokolskiy458
rubanvladimir374
Раисовна878