llmell6
?>

Кто-нибудб составить программу, которая присваивает значние константе рi=3.14 и выводит на экран значение этой константы

Информатика

Ответы

Валерьевич Николаевич1364
Const
Pi=3.14;

begin;
write(Pi);
end.
Nugamanova-Tatyana840
Нужно найти максимальное и минимальное из трёх чисел.
Пусть даны три числа x, y, z
Пусть:
m = min{x, y, z}, 
M = max{x, y, z},
r = max - min;
Теперь остаётся записать в качестве ответа число r, оно и будет разницей.

На C++ написал бы так:
#include <iostream>
using namespace std;

int maxNum(int x, int y, int z)
{
     if ((x>=y)&&(x>=z)) 
          return x;
      else if ((y>=x)&&(y>=z))
          return y;
      else
          return z;
}

int minNum(int x, int y, int z)
{
     if ((x<=y)&&(x<=z)) 
          return x;
      else if ((y<=x)&&(y<=z))
          return y;
      else 
          return z;
}

void main()
{
      setlocale(0, "Rus");
      int x, y, z;
      cout << "Введите через пробел 3 числа" << endl;
      cin >> x >> y >> z;
      cout << "Разница : " << maxNum(x,y,z) - minNum(x,y,z) << endl;
}
iv1as2
Uses crt;
const n=4;
      m=4;
var a: array [1..n,1..m] of integer;
    b: array [1..100] of integer;
    x,y,z,max,min,k: integer;
begin
     z:=1;
     for x:=1 to n do begin
         for y:=1 to m do
         begin
              a[x,y]:=random(20);
              write(a[x,y]:3);
         end;
         writeln;
         end;
     for y:=1 to m do begin
         max:=a[1,y];
         for x:=1 to n do
              if a[x,y]>max then max:=a[x,y];
         b[z]:=max;
         inc(z);
         end;
     min:=b[1];
     k:=z-1;
     for z:=1 to n do
         if b[z]<min then min:=b[z];
     writeln;
     writeln(min);
end.

---
Блок-схема во вложении
Программа на языке паскаль. дана матрица размера m*n. найти минимальный среди максимальных элементов

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто-нибудб составить программу, которая присваивает значние константе рi=3.14 и выводит на экран значение этой константы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sashab82
ckati
akbmaslafarkop3175
cetarbkilork82
melissa-80
Shipoopi8
yanermarina87
vardartem876
punchf
orion-inginiring7807
re-art
dilbaryan76
Olgera1
million2003
Test Станислав