f-d-a-14
?>

Нужно составить программу на языке pascal при сл. условиях: дан массив из десяти целых чисел: {2; -3; 5; 0; 7; -4; 1; -1; -6; 9} найти количество нулевых и количество отрицательных элементов массива.

Информатика

Ответы

wwladik2606222
Pascak abc
Программа во вложении
Sergeevna803
1.
const n=12; 
var
  a:array[1..n] of integer;
  i,max,imax,min,imin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)+150;
  Write(a[i]:4)
end;
writeln;
max:=a[1]; imax:=1;
min:=a[1]; imin:=1;
for i:=2 to n do 
 begin
 if a[i]>max then begin max:=a[i]; imax:=i; end;
 if a[i]<min then begin min:=a[i]; imin:=i; end;
 end; 
Writeln('max = a[',imax,'] = ',max,',  min = a[',imin,'] = ',min);
end.

Пример:
Исходный массив:
 170 165 194 186 165 161 174 172 177 191 158 181
max = a[3] = 194,  min = a[11] = 158

2.
const n=20; 
var
a:array[1..n] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i],' ')
end;
Writeln;
for i:=1 to n div 2-1 do
  for j:=1 to n div 2-i do
    if a[j]>a[j+1] then
    begin c:=a[j]; a[j]:=a[j+1]; a[j+1]:=c end;
Writeln('Измененный массив:');
for i:=1 to n do Write(a[i],' ');
Writeln
end.

Пример:
Исходный массив:
16 3 1 18 10 -12 -23 19 -5 -5 0 10 13 14 17 14 6 22 25 -22 
Измененный массив:
-23 -12 -5 -5 1 3 10 16 18 19 0 10 13 14 17 14 6 22 25 -22
zurabghiendzhoian886
//Dev C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    int n;
    cin>>n;
    cout<<endl;
    int **ma;
    ma=(int **)malloc(sizeof(int*)*n);
    for (int i=0;i<n;i++){
  ma[i]=(int*)malloc(sizeof(int)*n);}
    for(int i=0;i<n;i++){
            for(int j=0;j<n;j++)
              cin>>ma[i][j];
            cout<<endl;}
     for(int i=0;i<n-1;i++)
             for(int j=i+1;j<n;j++)
                         if(ma[i][j]!=ma[j][i]){
                         cout<<"NO";
                         cin.get();
                         cin.get();
                         return 0;}
     cout<<"YES";
     cin.get();
     cin.get();
     return 0;
}

Пример ввода:
4

1
2
3
4

2
1
2
3

3
2
1
4

4
3
4
1

Пример вывода:
YES

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно составить программу на языке pascal при сл. условиях: дан массив из десяти целых чисел: {2; -3; 5; 0; 7; -4; 1; -1; -6; 9} найти количество нулевых и количество отрицательных элементов массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatianamatsimoh
printdecor
vikabobkova2010
s45983765471717
Vetroff-11
Елена
mariyachervonnaya44
kronid12
PushkinaKurnosov984
Olgax732
Olga Arutyunyan
FATAHOVAMAINA
md-masya
anatolevich1931
office3