membuksdk
?>

Найдите все двузначные числа, сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9. нужно нарисовать алгоритм (блок-схему) и написать программу в visual basic-e. или хотя бы что-то из этого, .

Информатика

Ответы

premiumoft
Function ds(ByVal n As Integer) As Integer
    'Сумма цифр в числе n
    Dim s As Integer
    s = 0
    Do While n <> 0
        s = s + n Mod 10
        n = Int(n / 10)
    Loop
    ds = s
End Function

Function IsGood(n As Integer) As Boolean
    'Сохраняется ли сумма цифр при умножении числа на 2,3,..9 ?
    Dim etalon As Integer, k As Integer
    etalon = ds(n)
    IsGood = True
    k = 2
    Do While IsGood And k < 10
        IsGood = (ds(n * k) = etalon)
        k = k + 1
    Loop
End Function

Sub aaa()
    Dim i As Integer, s As String
    s = ""
    For i = 10 To 99
        If IsGood(i) Then s = s + Str(i)
    Next i
    MsgBox s
End Sub

Тестовое решение:
18 45 90 99
stic1995

#include <iostream>

typedef long long   ll;

using namespace std;

bool ll_is_valid(ll t, ll N, ll x, ll y)

{

return  t / x + (t - x) / y >= N;

}

ll f(ll N, ll x, ll y)

{

   ll R = 1;

   while (!ll_is_valid(R,N,x,y)) R *= 2;

ll L = R / 2;

while(R - L > 1)

{

 ll M   =   (L + R) / 2;

 

 if (!ll_is_valid(M,N,x,y)) {L = M;}

 else {R = M;}

}

return  R;

}

int  main()

{

ll N,x,y;

cin >> N >> x >> y;

if(x > y) swap( x, y );  

cout << f(N, x, y) <<  std::endl;

}

Koranna1986
// PascalABC.NET 3.0, сборка 1128
begin
  var a:=ArrRandom(20,-10,19);
  a.Println(','); // 1
  var b:=ReadArrInteger('Введите 10 целых чисел',10); // 2
  Writeln('Количество положительных элементов ',
    a.Where(x->x>0).Count); // 3
  for var i:=0 to 19 do
    if a[i]<0 then a[i]:=0;
  Writeln('Массив А после замены отрицательных'); a.Println(','); //4
  Writeln('Сумма положительных элементов ',
    a.Where(x->x>0).Sum) // 5
end.

Тестовое решение:
14,8,9,-5,6,3,3,-10,-8,18,7,13,2,17,-1,0,4,-3,8,-8
Введите 10 целых чисел -5 0 13 -7 -14 11 8 19 -3 -1
Количество положительных элементов 13
Массив А после замены отрицательных
14,8,9,0,6,3,3,0,0,18,7,13,2,17,0,0,4,0,8,0
Сумма положительных элементов 112

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найдите все двузначные числа, сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8 и 9. нужно нарисовать алгоритм (блок-схему) и написать программу в visual basic-e. или хотя бы что-то из этого, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

esnails17
Артур1807
evsyukov1997
elvini857
hrviko
rimmatrotskaia303
svetasvetlana429
Wlad967857
avdeevau807
MDubovikov73
Кириллов57
krisrespect2
akremlev2015
ganorussia
info9
▲