Vera_Shuklin
?>

Вкиоске продаётся газета стоимостью 250 руб и журнал стоимостью 900 руб. составить программу которая спрашивает р желании покупателя (купить журнал или газету), принимает деньги и выдаёт на экран сдачу

Информатика

Ответы

pifpaf85
Var
a,b,r,e:integer;
begin
a:=250;
b:=900;
writeln('Что вы желаете купить:');
writeln('1. Газету');
writeln('2. Журнал');
writeln('3. Газету и журнал');
readln(r);
if r=1 then e:=a
else
if r=2 then e:=b
else
e:=a+b;
writeln('Стоимость ',e,' р');
writeln('Введите деньги');
readln(r);
if r>e then
writeln('Ваша сдача ',r-e,'р')
else
writeln('Денег не хватает');
end.
ЭдуардовнаКлючников1361

116

Объяснение:

d = 100

для k от 5 до 12 выполнить

Действия в цикле:

1)  d = d - 6

2) d = d + 8

Вывод d

Цикл выполнится 8 раз

количество повторов в цикле равно конечное значение (12) переменной  счётчика (k) минус начальное  значение (5)  переменной  счётчика (k) плюс 1

количество повторов в цикле = 12 - 5 + 1 = 7 + 1 = 8

В цикле переменная d сначала уменьшается на 6, а затем увеличивается на 8.

В сумме эти действия (-6 + 8 = 2) увеличивают переменную d на 2.

Следовательно за весь цикл переменная d увеличится на 2 * 8.

Т.к. в начале программы d = 100, то

d = 100 + 2 * 8 = 100 + 16 = 116

ooo-helpvet44

{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).

Найти площадь треугольника (используя формулу Герона) }

uses crt;

var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;

begin

clrscr;

write('x1=');readln(x1);

write('y1=');readln(y1);

write('x2=');readln(x2);

write('y2=');readln(y2);

write('x3=');readln(x3);

write('y3=');readln(y3);

a:=sqrt(sqr(x1-x2)+sqr(y1-y2));

b:=sqrt(sqr(x2-x3)+sqr(y2-y3));

c:=sqrt(sqr(x3-x1)+sqr(y1-y3));

p:=(a+b+c)/2;

s:=sqrt(p*(p-a)*(p-b)*(p-c));

write('s=',s);

readln;

end.

формула герона!

А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !

периметр- это сумма всех сторон

например

begin

writteln( 'введите 3 стороны' ) ;

readln(a,b,c);

writeln(' периметр = ',a+b+c);

readln;

end.

Вот и все!! !

Удачи!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вкиоске продаётся газета стоимостью 250 руб и журнал стоимостью 900 руб. составить программу которая спрашивает р желании покупателя (купить журнал или газету), принимает деньги и выдаёт на экран сдачу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shoora
maestro6838
yrgenson2011801
gsktae7
gordeevadesign2986
Баканова1415
Avshirokova51
Сергеевна_Юрикович
kalterbrun
mahalama7359
dima-a
knyazev527
ravshandzon3019835681
maxkuskov2485
Хохлов