Mikuspavel2
?>

Составить программу, включающую меню из четырех пунктов: 1.создать текстовый файл из пяти строк-предложений. 2.вывести содержимое файла на экран. 3.вывести на экран количество слов, содержащих цифры. 4.выход. первые три пункта меню реализовать в процедурах, которые поместить в модуль. на делфи.

Информатика

Ответы

Вячеславовна_Сагитович
{ Запись 5 строк в файл }
procedure TForm1.Button1Click(Sender: TObject);
var outfile: TextFile;
begin
AssignFile(outfile, 'outfile.txt')
;Rewrite(outfile);
writeln(outfile, 'Привет из Delphi');
writeln(outfile, 'Моя программа работает, и выводит '
+'данный текст, чтобы доказать это...');
writeln(outfile, '3. Треться строка');
writeln(outfile, '234 четвертая');
writeln(outfile, 'Пятая строка');
CloseFile(outfile);
end;

// вывод на экран точнее в мемо или лист бокс

procedure TForm1.Button2Click(Sender: TObject);
begin 
// выводим в мемо
 Memo1.Lines.LoadFromFile('outfile.txt');
// либо в лист бокс как тебе лучше
 ListBox1.Items.LoadFromFile('outfile.txt');
end;

// кнопка для закрытия 

procedure TForm1.Button3Click(Sender: TObject);
begin 
Close;
end;

// событие onClose

procedure TForm1.FormClose(Sender: TObject; var CloseAction: TCloseAction);
begin
  if MessageDlg('Вы точно хотите выйти?',     mtConfirmation, mbOkCancel,0)= mrOk then begin     
CloseAction:= caFree;   
     end
  else begin
     CloseAction:= caNone;
  end;
end;

ЗДЕСЬ!
outfile.txt - это ваш файл(может создаваться автоматически

ЧТО НУЖНО СДЕЛАТЬ?
1. Закинуть на форму 3 кнопки
2. Закинуть ListBox или Memo
3. В событиях формы в инспекторе объектов (Инспетор Объектов/ События/ onClose) в onClose выбрать процедуру FormClose
ka-shop

1. нет ответа

4. а) сжать изображения

    б) удалить встроенные шрифты

5 фотографий

Объяснение:

1. таблицы наверное забыли загрузить...

4. а) с любого графического редактора изменить параметры изображений

   б) удалить встроенные шрифты

   в) можно еще упаковать документ с архиватора, но самый лучший выход почистить наконец флешку от ненужного хлама. Но это для ответа не годится, т. к. не соблюдаются условия задачи.

5.

1 Гб = 1 * 1024 * 1024 = 1048576 Кб - память фотоаппарата

1048576 Кб / 30720 Кб = 34,133333333333333333333333333333 - всего фотографий

34 - 29 = 5 - осталось

Voshchula David393

Объяснение:

Вы можете уменьшить размер файлов и сэкономить пространство на диске с сжатия рисунков в документе. Параметры сжатия уменьшают как размер файл, так и размеры рисунков, в зависимости от того, как планируется использовать изображение, например для просмотра на экране или в сообщении электронной почты. Сжать можно все рисунки в файле или только специально выделенные.

Если документ сохранен в более старом формате DOC, то параметр "Уменьшить размер файла" не будет доступен в меню "Файл". Чтобы использовать параметр "Уменьшить размер файла", сохраните документ в новом формате DOCX.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, включающую меню из четырех пунктов: 1.создать текстовый файл из пяти строк-предложений. 2.вывести содержимое файла на экран. 3.вывести на экран количество слов, содержащих цифры. 4.выход. первые три пункта меню реализовать в процедурах, которые поместить в модуль. на делфи.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vova220
ognevasv555
Yezhov_igor42
kseniay2006548
seymurxalafov05
mileva84
sv-opt0076
oldulo74
владимировнаКлютко
lsyrbu
danaya3005
ann-perminova2008
Виктория1690
Что будет выведено? 1+3=4​
Kulikov1065
Екатерина15