academycoffee243
?>

Дана последовательность действительных чисел а1, . заменить все её члены, больше данного z, этим числом. подсчитать количество замен. , , написать программу. я запуталась что-то.

Информатика

Ответы

dima-a
Var ar:array of integer;
z,i,n,o:integer;
begin;
o:=0;
readln(n);
readln(z);
setlength(ar,n+1);
for i:=1 to n do
begin;
readln(ar[i]);
if ar[i]>z then
begin;
inc(o);
ar[i]:=z;
end;
end;
writeln('Array:');
for i:=1 to n do
write(ar[i]:4);
writeln;
writeln('Количество замен=',o);
end.
Anna389
1. Если буквально по тексту задания, то число должно быть должно быть однозначным, тогда число будет соответствовать цифре.

2. Если имелось ввиду, что вводится символ и надо выяснить является ли введенный символ цифрой, то можно применить функцию StrToInt от введенного символа, если в результате получится цифра, то вводили символ - цифру.

Для первого варианта можно попробовать такое решение:

Var
  a :integer;
Begin
  writeln('Введите цифру ');
  readln(a);
  case a of
    0 : writeln ('ноль');
    1 : writeln ('один');
    2 : writeln ('два');
    3 : writeln ('три');
    4 : writeln ('четыре');
    5 : writeln ('пять');
    6 : writeln ('шесть');
    7 : writeln ('семь');
    8 : writeln ('восемь');
    9 : writeln ('девять')
  else writeln ('Это число не цифра');
  end;
end.
  
annayarikova
Program dates;
var
date : string;
dd, mm, yy : string;
d, m, y : integer;

function strMonth(dt : integer) : string;
var
res : string;
begin
res:='';
case dt of
1 : res:=' января ';
2 : res:= ' февраля ';
3 : res:= ' марта ';
4 : res:= ' апреля ';
5 : res:= ' мая ';
6 : res:= ' июня ';
7 : res:= ' июля ';
8 : res:= ' августа ';
9 : res:= ' сентября ';
10 : res:= ' октября ';
11 : res:= ' ноября ';
12 : res:= ' декабря ';
end;
strMonth := res;
end;

begin
write('Введите дату:');
readln(date);
dd:=copy(date, 1, 2);
mm:=copy(date, 4, 2);
yy:=copy(date, 7, 4);
val(dd, d);
val(mm, m);
val(yy, y);
writeln('Сегодня ', d, strMonth(m), y, ' года');

end.

Напишите программу . условие такое: вводится дата например 05.04.2016, программа должна вывести что

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана последовательность действительных чисел а1, . заменить все её члены, больше данного z, этим числом. подсчитать количество замен. , , написать программу. я запуталась что-то.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mariya987
yfetyukov
Versalmoda
Panei
aureole6452
fednik3337923
Prostofil200790
ainred
Девяткина_Арсений
Придумать свою программу «Маневр»​
romolga3580
Дмитрий Бундин
stark11
bestxbox
Alisa
Татьяна
▲