kapi30
?>

Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2)минимальное значение; 3)среднее арифметическое значение.

Информатика

Ответы

avakarica

program n1;   const n=10;   var  mas: array[1..n] of integer;   i: integer;   max,min,sum: integer;   ar: real;   begin    for i: =1 to n dobegin  mas[i]: = random (20)-10;   write(mas[i],' ');   writeln  end;   max: =1;     for i: =2 to n do    if mas[i]> mas[max] then    max: =i;     writeln;     writeln('максимаьное значение a[',max,']= ',mas[max]);       min: =1;   for i: =2 to n do    if mas[i]< mas[min] then    min: =i;     writeln;     writeln(минимальное значение a[',min,']= ',mas[min]);       for i: =1 to n do    sum: =sum+mas[i];       ar: =sum/n;     writeln;     writeln('среднее арифметическое =  ',ar);     end.{немного нерационально но работает=)}

sport2293032
1) количество лампочек 4.     каждая лампочка может иметь только два состояния:           загораться красным или зелёным цветом. максимальное количество   передаваемых сигналов =2^4 =16 (но, если учесть, что лампочка может быть выключена, то у каждой лампочки три состояния: выключена, красная и зелёная, в этом случае макс. количество передаваемых сигналов = 3^4= 81) 2) количество лампочек 4.       каждая имеет   только  три состояния: красная, зелёная, синяя. макс. кол-во передаваемых сигналов = 3^4=81. (с учётом того, что каждая лампочка может быть выключена, то у неё четыре возможных состояния: выключена, красная, зелёная,синяя, тогда макс. кол-во сигналов = 4^4= 256)
Хромов1501
Формат. формат шрифта подразумевает под собой: выбор подчеркивания; подбор ширины; определение цвета шрифта; выбор шрифта; подбор начертания; выбор размера; кернинг шрифта; смещение  шрифта; шрифтовые спецэффекты; индексацию.характеристики шрифта: гарнитура, кегль, начертание, ширина, подчеркивание, кернинг, цвет шрифта, смещение символов шрифта, параметры анимации, индексация, регистр шрифта.но если попроще: шрифтов много, отличаются они друг от друга по 3-м параметрам: гарнитура,  размер символов,  начертание.а все остальное - лишь детализация.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2)минимальное значение; 3)среднее арифметическое значение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Viktor1316
annazhurawlewa
Asplaksina
ev27076878
lorsam36
ElenaSkvortsova2
voloshin238
Суравцова_Алексей669
titancore
ooomedray4
libirishka7910
mamanger
yuraotradnov
Владислав-Александр32
Rik200081490