sveremeev816
?>

Используя циклы решить в паскале: 1) ввести число и вывести все его делители 2) составить программу, планирования закупки товаров в магазине на сумму, не превышающую заданной величины.

Информатика

Ответы

agitahell149

1.

program xxx;

var i, n : integer

begin

  writeln ('введите число n=');

  readln (n);

  writeln ('делители числа: ');

  for i: = 1 to n do

      if n mod i = 0 then writeln (i);

  readln

end.

ЛАРИСА Насоновская231
Var   xl,xr,h,x: real;   i: integer; begin   write('введите левую и правую границы изменения х, затем шаг: ');   read(xl,xr,h);   for i: =1 to trunc((xr-xl)/h)+1 do begin       x: =xl+(i-1)*h;       writeln(x: 0: 4,'  ',abs(sin(x))+cos(abs(       end end. пример введите левую и правую границы изменения х, затем шаг: 1.2 3 0.18 1.2000  1.2943968404439 1.3800  1.17149436167019 1.5600  1.01073783728823 1.7400  0.817321730886476 1.9200  0.597495822534427 2.1000  0.358363262049017 2.2800  0.107651047653376 2.4600  -0.146539653537401 2.6400  -0.395995275405633 2.8200  -0.632655254626053 3.0000  -0.848872488540578
koochma
1) это полное имя файла 2) это путь до папки "system" 3) это относительное имя файла 4) это относительное имя файла 5)  это  относительное имя файла, без расширения скорей всего, тут имелось ввиду имя файла, находящееся в текущем каталоге. ответ: 4 p.s. в принципе, именем файла   может быть  и exe, если оно не является расширением. если в в 5 варианте ответа перед exe не стоит точка, то это может быть именем файла. но, если перед exe стоит точка, то это расширение имени файла..

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя циклы решить в паскале: 1) ввести число и вывести все его делители 2) составить программу, планирования закупки товаров в магазине на сумму, не превышающую заданной величины.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dokmak140652
Дмитрий74
smokestylemos
AleksandrIvanovich1273
goldenshtein33333
Galinova2911
tatianaesipenko
pechyclava
savva-vika
Pavlushina-Novikova
Дмитрий1974
Korobeinikov-Yulich23
julichca68
oksanamalakhova004610
yda659