# 1 рівень
from tkinter import *
root = Tk()
root.geometry("200*300")
def command_b():
Label(text="DWD").pack()
root.geometry("100x150")
b = Button(text="asdf", command = command_b)
b.pack()
root.mainloop()
# 2-3 рівень
from tkinter import *
root = Tk()
def printer():
Label(text="Характеристики принтера").pack()
def scaner():
Label(text="Характеристики сканера").pack()
def klaviatura():
Label(text="Характеристики клавиатуры").pack()
b1 = Button(text="Принтер", command=printer)
b2 = Button(text="Сканер", command=scaner)
b3 = Button(text="Клавиатура", command=klaviatura)
b1.pack()
b2.pack()
b3.pack()
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
С++ так что бы программа просила в вести значение на 1.напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры 2.найти среднее арифметическое всех целых чисел от 1 до 1000. 3.пользователь вводит две границы диапазона, вывести на экран все числа из этого диапазона. предусмотреть, чтобы пользователь мог вводить границы диапазона в произвольном порядке. вывести все четные числа из диапазона. вывести все нечетные числа из диапазона. вывести все числа, кратные семи 4.пользователь с клавиатуры вводит числа. посчитать их сумму и вывести на экран, как только пользователь введет ноль.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
long sum = 0;
int a;
cout << "Введите a" << endl;
cin >> a;
if (a > 500)
{
cout << "а > 500" << endl;
}
else
{
sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
cout << sum;
}
}
2.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
double average = (1 + 1000) / 2.;
cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;
}
3
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, b = 0;
cout << "Введите границы диапазона" << endl;
cin >> a >> b;
cout << "Все числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
cout << i << endl;
}
}
else
{
for (int i = b; i < a; i++)
{
cout << i << endl;
}
}
cout << "Чётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
cout << "Нечётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
cout << "Числа, кратные 7:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
}
4.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, sum = 0;
cout << "Введите числа" << endl;
while (true)
{
cin >> a;
if (a == 0)
{
break;
}
sum += a;
}
cout << "Сумма =" << sum << endl;
}