ВалентиновичСуриковна1104
?>

Склавиатуры одной строкой вводят имя и фамилию. составьте программу, которая выводит сначала фамилию, а затем имя.

Информатика

Ответы

sayfullinmr

program pr; vars,n: string; c: char; i: integer; beginwriteln('введите имя и фамилию в одной строке'); readln (s); i: =1; while s[i]< > ' ' do i: =i+1; n: =copy(s,1,i-1); writeln(n); readln; end.

zubov-073620
Сумма всех четных чисел от 1 до 200 - это на самом деле сумма чисел 2+4+6++198+200. 1. самый короткий вариант // pascalabc.net 3.1, сборка 1219 от 16.04.2016 begin   writeln(range(2,200,2).sum) end. результат: 10100 2. более длинный и более "школьный" вариант // pascalabc.net 3.1, сборка 1219 от 16.04.2016 begin   var s: =0;   var i: =2;   while i< =200 do begin       s: =s+i;       i: =i+2       end;   writeln(s) end. 3. совсем "тупой школьный" вариант (решение "в лоб") // pascalabc.net 3.1, сборка 1219 от 16.04.2016 var   i,s: integer; begin   s: =0;   for i: =1 to 200 do       if i mod 2 =0 then s: =s+i;   writeln(s) end. 4. улучшенный "школьный" вариант // pascalabc.net 3.1, сборка 1219 от 16.04.2016 var   i,s: integer; begin   s: =0;   for i: =1 to 100 do s: =s+2*i;   writeln(s) end.
zsv073625
№1 //pascalabc.net (версия 3.1, сборка 1210 от 29.03.2016) var   b: array of real;   i, n,pn: integer;   ps,op,min: real; begin   write('количество элементов массива : '); readln(n);   setlength(b, n); // задаем длину массива   min: =maxreal; op: =1;   writeln('исходный массив: ');   for i: =0 to n-1 do begin       repeat           write('введите ',i+1,' число из ',n,' : '); readln(b[i]);       until (b[i]< =5) and (b[i]> =-20);       if (b[i]> 0) and (round(b[i]/2)*2=b[i]) then begin           ps +=b[i]; pn+=1;           end       else if b[i]< 0 then  op *=b[i];       if b[i]< min then min: =b[i];   end;   writeln;   writeln('сумма положительных и четных элементов массива : ',ps: 0: 3);   writeln('среднее положительных и четных элементов массива : ',ps/pn: 0: 3);   writeln('произведение отрицательных элементов массива : ',op: 0: 3);   writeln('минимальный элемент массива : ',min);   writeln('отсортированный массив по убыванию : ');   b.sorteddescending.println; end. тестовое решение: количество элементов массива : 8 исходный массив: введите 1 число из 8 : -18.5 введите 2 число из 8 : 3.4 введите 3 число из 8 : 4 введите 4 число из 8 : -12 введите 5 число из 8 : 2.2 введите 6 число из 8 : -6.3 введите 7 число из 8 : 2 введите 8 число из 8 : 5 сумма положительных и четных элементов массива : 6.000 среднее положительных и четных элементов массива : 3.000 произведение отрицательных элементов массива : -1398.600 минимальный элемент массива : -18.5 отсортированный массив по убыванию : 5 4 3.4 2.2 2 -6.3 -12 -18.5 №2 //pascalabc.net (версия 3.1, сборка 1210 от 29.03.2016) var   a: array of integer;   i,n ,max,h,k: integer; begin   write('количество элементов массива : '); readln(n);   write('число h : '); readln(h);   write('число k : '); readln(k);   setlength(a, n); // задаем длину массива   max: =-maxint;   writeln('исходный массив: ');   for i: =0 to n-1 do       repeat           write('введите ',i+1,' число из ',n,' : '); readln(a[i]);           if a[i]> max then max: =a[i];       until (a[i]< =7) and (a[i]> =-12);   for i: =0 to n-1 do begin        if (a[i]> h) and (a[i]mod k=0) then           writeln('число ', a[i],' больше ',h,' и кратно ',k);   end;   writeln('максимальный элемент массива : ',max);   writeln('отсортированный массив по возрастанию : ');   a.sorted.println; end. тестовое решение: количество элементов массива : 8 число h : -8 число k : 2 исходный массив: введите 1 число из 8 : -10 введите 2 число из 8 : 6 введите 3 число из 8 : -4 введите 4 число из 8 : 3 введите 5 число из 8 : 1 введите 6 число из 8 : -1 введите 7 число из 8 : -12 введите 8 число из 8 : 4 число 6 больше -8 и кратно 2 число -4 больше -8 и кратно 2 число 4 больше -8 и кратно 2 максимальный элемент массива : 6 отсортированный массив по возрастанию : -12 -10 -4 -1 1 3 4 6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры одной строкой вводят имя и фамилию. составьте программу, которая выводит сначала фамилию, а затем имя.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatiyanabe2013727
dimiff5
Диана-Николаевна377
Анатольевич
Mariya Filippov
korotinadasha07
sergeychelyshev197618
kristeisha871
dkvsadovoe
janepustu
Larisa-0888716
НиканоровСалиев675
brand
oksit
gbfedak220