olkay
?>

Составить программу, которая считывает число и выводит его модуль (примечание: если число отрицательное, необходимо его умножить его на -1 на языке паскаль

Информатика

Ответы

yulyazhdan
Var
c:real;
begin
writeln('Введите число');
readln(c);
if c<0 then c:=c*-1;
writeln('Модуль числа=',c);
end.
lidiya08083268

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

AndrukhovichKonovalov

Насколько я понял n должна быть меньше или равна 100, верно? Тогда вот, он, может и не самый эффективный, но довольно понятный и работающий.

#include <iostream>

using namespace std;

int main(){

int n,maks,schetchik; /* n - это количество элементов массива, maks - думаю, знаешь, schetchik - высчитывает количество повторений максимального числа в массиве */

cin >>n;

if(n<=100){

int a[n]; /*обьявляем количество эелементов массива и проверяем, чтобы его количество было меньше или равно 100*/

for(int i=0;i<n;i++){ /*цикл for обьявляет переменную i, далее делая её текущим индексом элемента массива */

cin >> a[i];

if (a[i]>-30000 && a[i]<30000){ /* проверка условия, данного задачей
*/

if(i==0){maks=a[i]; schetchik =1;}; /* особая разработка автора, максимальным элементом массива становиться самый первый элемент (ну по крайней мере, я ни у кого не видел) */

if (i!=0 && maks == a[i]) {schetchik +=1;}; /* и ещё одна моя собственная разработка, проверка, не является ли элемент массива первым, а так же если он равен максимальному, то счетчик увел. на 1 */

if (maks<a[i]) {maks = a[i]; schetchik = 1; }; /* а тут мы проверяем на то, не являеться ли текущий массив большим чем максимальный, если да, то счет сбрасывается и макс. равняется текущему числу */

}

}

cout << schetchik; } //ну и вывод числа, всё довольно просто

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая считывает число и выводит его модуль (примечание: если число отрицательное, необходимо его умножить его на -1 на языке паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Devaunka40
balabina-Olesya
Алексей Шуклин
Yekaterina358
mantseva
dentinnsmr467
Хромов1501
lenapopovich556510
fominovaVladislav1346
prostopo4ta29
waspmoto6188
bogdanyukn562
ekaizer
oniks-plus
vera-sherepa231