okutihamv
?>

Составить программу, которая выполняет подсчет размера оплаты за электроэнергию по введенным значениям расхода электроэнергии и тарифа (тариф – стоимость 1 квт*ч)

Информатика

Ответы

VolkovaMaslova
Var a,b:integer; 
begin 
writeln('Введите расход электроэнергии'); 
read(a); 
writeln('Введите тариф'); 
read(b); 
writeln('Оплата за электроэнергия = ',a*b); 
end.
kazan-ugoop36

1 (истинное высказывание)

Объяснение:

((2*2=4) V (3*3=10)) & ((2*2=5) V (3*3=9)) = (1 V 0) & (0 V 1) = 1 & 1 = 1

(2*2=4) = 1 (истинное высказывание, т.к. 2 * 2 = 4)

(3*3=10) = 0 (ложное высказывание, т.к. 3 * 3 ≠ 10)

(2*2=5) = 0 (ложное высказывание, т.к. 2 * 2 ≠ 5)

(3*3=9) = 1 (истинное высказывание, т.к. 3 * 3 = 9)

Общий порядок действий:  

1) скобки

2) НЕ (¬, черта над выражением) - значение противоположно исходному высказыванию  (здесь нет)

3) И (&, ∧) - истинно, когда оба исходных высказывания истинны  

4) ИЛИ (∨) - ложно, когда оба исходных высказывания ложны  

Vasilevich Fokin
1)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 3 == 0)
{cout << str[i] << endl;}
}
_getch();
return 0;
}
2)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{ string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
 if (i % 2 == 0)
 { if (str[i] != 'a')
  { str[i] = 'a'; }
  if (str[i] != 'b')
  { str[i] = 'b'; }
  if (str[i] != 'c')
  { str[i] = 'c'; }
}
}
cout << str << endl;
_getch();
return 0;}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая выполняет подсчет размера оплаты за электроэнергию по введенным значениям расхода электроэнергии и тарифа (тариф – стоимость 1 квт*ч)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vera-classic75
strager338
vlebedeva81
rosik76
annashersheva
jim2k
ktripoleva294
mursvita943
Yelena_Yuliya1847
ksoboleva
klkkan
ariyskayaa5
Artur-62838
kuzinnv1968
kovalenko262