arch5050
?>

1. составьте программу, решающую следующую : с кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. какое наименьшее количество (k) коробок потребуется для перевозки n килограмм конфет? вводимое и в ыводимое . для заданного числа суток определить количество часов, минут и секунд. вводимое количество сутоквыводимое количество часов, минут, секунд7 суток= 168 часов = 10080 минут = 604800 секунд1 сутки= 24 часов = 1440 минут = 86400 секунд10 суток= 240 часов = 14400 минут = 864000 секунд2 суток= 48 часов = 2880 минут = 172800 секунд

Информатика

Ответы

kareeva
Вроде должна работать это 1 задача

uses crt;
var a,i,j,n:integer;
begin
writeln('ВВедите кол. конфет в (кг)');
read(a);
n:=0;
if a>=10 then begin n:=n+ a div 10; a:=a-(a div 10*10); end;
if (a>=5) and (a<10) then begin n:=n+ a div 5; a:=a-(a div 5*5); end;
if (a>=1) and (a<5) and (a<10) then begin n:=n+ a div 1; a:=a-(a div 1*1); end;
writeln('Общее количество коробок = ',n);
end.

2 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('Введите кол. суток');
read(a);
writeln('Количество часов в ',a,' сутках = ',a*24);
writeln('Количество минут в ',a,' сутках = ',a*24*60);
writeln('Количество секунд в ',a,' сутках = ',a*24*60*60);
end.
avn23

                     a |                   s |          k

       5,000000 |   0,000000 |   0,000000

       9,000000 |   5,000000 |   1,000000

      13,000000 |  14,000000 |   2,000000

      17,000000 |  27,000000 |   3,000000

      21,000000 |  44,000000 |   4,000000

      25,000000 |  65,000000 |   5,000000

      29,000000 |  90,000000 |   6,000000

      33,000000 | 119,000000 |   7,000000

      37,000000 | 152,000000 |   8,000000

      41,000000 | 189,000000 |   9,000000

      45,000000 | 230,000000 |  10,000000

      49,000000 | 275,000000 |  11,000000

      53,000000 | 324,000000 |  12,000000

K = 12.0

chavagorin

                    a |                   s |          k

      5,000000 |   0,000000 |   0,000000

      9,000000 |   5,000000 |   1,000000

     13,000000 |  14,000000 |   2,000000

     17,000000 |  27,000000 |   3,000000

     21,000000 |  44,000000 |   4,000000

     25,000000 |  65,000000 |   5,000000

     29,000000 |  90,000000 |   6,000000

     33,000000 | 119,000000 |   7,000000

     37,000000 | 152,000000 |   8,000000

     41,000000 | 189,000000 |   9,000000

     45,000000 | 230,000000 |  10,000000

     49,000000 | 275,000000 |  11,000000

     53,000000 | 324,000000 |  12,000000

K = 12.0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу, решающую следующую : с кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. какое наименьшее количество (k) коробок потребуется для перевозки n килограмм конфет? вводимое и в ыводимое . для заданного числа суток определить количество часов, минут и секунд. вводимое количество сутоквыводимое количество часов, минут, секунд7 суток= 168 часов = 10080 минут = 604800 секунд1 сутки= 24 часов = 1440 минут = 86400 секунд10 суток= 240 часов = 14400 минут = 864000 секунд2 суток= 48 часов = 2880 минут = 172800 секунд
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

r682dm2011
Larax0819
mali2681208
volkovaoksana19806037
Vrpeshka
Artyom
mishink535
annashaykhattarova1
Espivak
annakuzina2023
Baidina
Ольга
davidovalbert6
Яна_Софья
beast05031075
▲