?>
Решить две надо, завтра урок ! 1)напишите программу, которая вводит четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получится число 4231. 2)напишите программу, которая вводит четырёхзначное натуральное число и "вырезает" из него вторую цифру с начала, например, из числа 1234 должно получиться число 134.
Ответы
var x:integer;
begin
writeln('Введите четырехзначное число');
read(x);
x:=x mod 10*1000+x div 100 mod 10*100+x div 10 mod 10*10+x div 1000;
writeln('Число после перестановки 1-й и 4-й цифры = ',x);
end.
Задание №2
var x:integer;
begin
writeln('Введите четырехзначное число');
read(x);
x:=x div 1000*100+x div 10 mod 10*10+x mod 10;
writeln(x);
end.