tatk00
?>

Даны целые числа а в с написать программу, подсчитывающую сумму тех чисел из данных, которые больше 0

Информатика

Ответы

oksana-popova
Class CertainSum{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  long a = in.nextLong(), b = in.nextLong(), c = in.nextLong();
  System.out.print((a<0?0:a)+(b<0?0:b)+(c<0?0:c));
 }
}
dima0218687
A = int(input())if 1: print('Зима')else:  if 2: print("Зима")  else:    if 3: print("Весна")    else:      if 4: print("Весна")      else:        if 5: print("Весна")        else:          if 6: print("Лето")          else:            if 7: print('Лето')            else:              if 8: print("Лето")              else:                if 9: print("Осень")                else:                  if 10: print("Осень")                  else:                    if 11: print("Осень")                    else:                       if 12: print("Зима")                      
bolosolo77
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(100,-1000,1000); a.Println;
  var imax:=a.IndexMax;
  var imin:=a.IndexMin;
  Writeln('Индекс минимального ',imin+1,', максимального ',imax+1);
  if imin>imax then Swap(imin,imax);
  Writeln('Сумма на участке: ',a[imin:imax+1].Sum)
end.

Пример
-65 273 -273 58 108 919 -114 -119 -848 -24 301 -497 348 -386 -235 421 -907 -891 -151 675 -185 89 -991 -276 -802 914 959 -64 848 911 573 -941 59 -522 -460 890 963 840 85 -932 -974 -110 -698 785 537 867 778 -889 239 -659 -972 655 665 -136 555 847 263 -998 -141 194 961 950 34 -758 403 242 444 -130 -927 -124 459 -747 25 -220 649 925 -214 -775 188 -668 -865 847 698 506 882 919 -606 -806 -76 -306 -374 960 -19 891 -892 -923 857 -940 -619 -706
Индекс минимального 58, максимального 37
Сумма на участке: 1711

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны целые числа а в с написать программу, подсчитывающую сумму тех чисел из данных, которые больше 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

atlantika7
savenko0109152
anyakru94
fedoseevgleb
Alsergus7811
yaelenatu
Косарев
Ryadovboxing23
kristina1989
galkavik
modellisimo-a
krutikovas
mos-5nica
a800000
blagorodovaanna375
▲