Var a:integer; begin a:=0; while a<20 do begin a:=a+2; write(a,' '); end; end.
Результат: 2 4 6 8 10 12 14 16 18 20
saytru5850
06.06.2021
Пусть а - число правильных ответов, с - число неправильных ответов. тогда число вопросов, на которые ответы даны не были - 25-а-с 5*а-9*с=40 с у нас больше либо равно 1, тогда делаем методом подстановки, не забывая, что а - обязательно целое число. с=1 5а-9=40, 5а=49, а - число не целое, значит, не подходит. с=2 5а-18=40, 5а=58, а - число не целое, значит, не подходит. с=3 5а-27=40, 5а=67, а - число не целое, значит, не подходит. с=4 5а-36=40, 5а=76, а - число не целое, значит, не подходит. с=5 5а-45=40, 5а=85, откуда а =17. ответ: 17.
yna21289
06.06.2021
Const n = 5; var i: integer; a: array[1..n * 2 + 1] of integer; begin writeln('исходный массив: '); for i : = 1 to 2 * n do begin a[i] : = random(99) + 1; write(a[i] : 5); end; for i : = 2 * n + 1 downto n + 1 do a[i] : = a[i - 1]; a[n + 1] : = 0; writeln(); writeln('полученный массив: '); for i : = 1 to 2 * n + 1 do write(a[i] : 5); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, использую цикл while do. вывести числа в следующем порядке 2, 4, 6, 8 , 10 паскаль
begin
a:=0;
while a<20 do
begin
a:=a+2;
write(a,' ');
end;
end.
Результат:
2 4 6 8 10 12 14 16 18 20