simonovaliubov5852
?>

Написать программу на паскале абс цикл с постусловием дано целое число n (> 1 вывести наименьшее из целых чисел k, для которых сумма 1 + 2 + … + k будет больше или равна n, и саму эту сумму.

Информатика

Ответы

moskvichkabakery56
Var n,k,summ:integer;
begin
  write('Введи число N: ');
  readln(n);
  repeat begin
     k:=k+1;
     summ:=summ+k;
     end;
  until summ>=n;
  writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.  
komarov-dmitriy
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№6

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99).Println;
  Writeln('[',a.Min,';',a.Max,']')
end.

Пример
n= 13
72 -77 -88 -99 -2 -61 67 40 -30 -28 91 -56 29
[-99;91]

№9

begin
  var a:=ReadArrReal('Вводите:',ReadInteger('n='));
  Writeln('Положительных: ',a.Where(t->t>0).Count);
  Writeln('Отрицательных: ',a.Where(t->t<0).Count);
  Writeln('Нулевых: ',a.Where(t->t=0).Count)
end.

Пример
n= 10
Вводите: 3.7 12.6 -4 0 -13.2 0.7 0 14 2.12 0.004
Положительных: 6
Отрицательных: 2
Нулевых: 2

№16

begin
  var a:=Arr(-3.7,-3.1,-2.3,-1.6,-0.9,-0.2,0.5,1.2,1.9,2.6,3.3,4.0,4.2,5.4,
      1.92,1.76,1.52,1.26,0.95,0.45,0.71,1.10,1.38,1.61,1.82,2.00,2.05,2.32);
  var d:=a.Length div 2;
  for var i:=0 to d-1 do Writeln(a[i]:5:2,a[i+d]:20:3)
end.

Результат
-3.70               1.920
-3.10               1.760
-2.30               1.520
-1.60               1.260
-0.90               0.950
-0.20               0.450
 0.50               0.710
 1.20               1.100
 1.90               1.380
 2.60               1.610
 3.30               1.820
 4.00               2.000
 4.20               2.050
 5.40               2.320

№19

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var i:=1;
  while i<=n do begin
    Print(a[i-1]);
    i*=2
    end;
  Writeln
end.

Пример
n= 17
-43 -41 -37 -43 12 45 -34 -19 -38 33 -34 39 -40 33 -46 4 39
-43 -41 -43 -19 4
borzhemskaya19823110
1 задание) ответ: 1323141;
Двигаемся в обратном порядке 2324142 (идём с конца) ей противоположные 1323141
2 задание) ответ: 2949;
мы должны получить 11 и 13 причем минимально . можем только так 9+2 и 9+4 . значит 2949
3 задание)   ответ: 3;
чтобы добраться до 21 нам нужно выполнить 1 команду 6 раз и 3 раза вторую , нас спрашивают про вторую пишем ответ 3
4 задание) ответ: 1;
нам нужно число которое делится на 5 то есть 4 отпадает , и также нам нужно чтобы модуль разности был не более 2 и во втором и в третьем модуль разности больше 2 , остается 1.
5 задание)  ответ: 1112221;
Я всегда начинаю с обратного 
57-56-28-14-7-6-5-4  собираем с конца 1112221 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале абс цикл с постусловием дано целое число n (> 1 вывести наименьшее из целых чисел k, для которых сумма 1 + 2 + … + k будет больше или равна n, и саму эту сумму.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lugovoi
Andreevna_Grebenshchikova155
Andei
Коваль1974
alislisa191
tenvalerij
AleksandrovnaIgor
ktatarinova
rb-zakaz
adminaa
lena260980
mushatolga
samiramoskva
ustinovda14
Vyacheslavovna1108