zverevahelen
?>

Составить программу, в паскале вычисляющую стоимость покупки из нескольких тетрадок, ручек, карандашей. стоимость и кол-во вводить с клавиатуры.

Информатика

Ответы

kisuhakisa
//Pascal ABC.NET v3.0 сборка 1111

Var
 r,t,k,rc,tc,kc:integer;
begin
 writeln('Введите кол-во ручек, тетрадок и карандашей соответственно');
 read(r,t,k);
 writeln('Введите стоимость ручек, тетрадок и карандашей соответственно');
 read(rc,tc,kc);
 writeln('Цена всех ручек=',rc*r);
 writeln('Цена всех тетрадок=',tc*t);
 writeln('Цена всех карандашей=',kc*k);
 writeln('Сумма покупок=',rc*r+tc*t+kc*k);
end.
fishka-sokol14
1)uses crt;
var i,j,n,ans:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
ans:=ans+1;
writeln(ans);
end.
2)
uses crt;
var i,n:integer;
x:array[1..100] of integer;
begin
writeln('Введите количество x и значения: ');
read(n);
for i:=1 to n do
read(x[i]);
writeln('x  y');
for i:=1 to n do
writeln(x[i],'  ',x[i]*x[i]+3);
end.
3.
uses crt;
var i:integer;
begin
for i:=1 to 5 do
write(i*i*i,' ');
end.
4.
uses crt;
var i,n,sum:real;
begin
writeln('Введите N:');
read(n);
i:=3;
while i<=n do
begin
sum:=sum+1/i;
i:=i+3;
end;
writeln(sum);
end.
5.
uses crt;
var j,i,n,sum:integer;
a:array[1..100] of integer;
begin
writeln('Введите количество чисел и сами числа:');
read(n);
for i:=1 to n do
begin
sum:=0;
read(a[i]);
for j:=1 to length(inttostr(a[i])) do
sum:=sum+strtoint(inttostr(a[i])[j]);
if sum mod 3 = 0 then
write(a[i],' ');
end;
end.
6.a)uses crt;
var n:string;
begin
read(n);
writeln(max(strtoint(n[1]),strtoint(n[2])));
end.
б)
uses crt;
var n:string;
begin
read(n);
writeln(max(max(strtoint(n[1]),strtoint(n[2])),strtoint(n[3])));
end.
catsk8

Первое задание:

1) 3

2) 6

3) 5

Второе задание:

1) 1

2) 3

Третие:

//Язык программирования java

package com.niksonbinsk;

import java.util.ArrayList;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       int space_left = 0;

       int count = 0;

       Scanner s = new Scanner(System.in);

       ArrayList<Integer> str = new ArrayList<>();

       while(space_left != 30){

           System.out.println("Enter next num:");

           str.add(s.nextInt());

           space_left++;

       }

       for(int i =0;i<30;i++){

           if(str.get(i) % 2 == 0){

               count++;

           }

       }

       System.out.println(count);

   }

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, в паскале вычисляющую стоимость покупки из нескольких тетрадок, ручек, карандашей. стоимость и кол-во вводить с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Amelin-Alipova
Vik1744184
asi19776
Lapushkin1988
Kuznetsova702
insan10
snab54
Aleksei Aleksandrovna649
diana0720
echervyakov
severbykova
julichca68
osandulyak
nekrasovaolga27
hbqhzwtd
▲