Sergeevna-Makarov
?>

Напишите программу, которая вводит с клавиатуры 10 реальных чисел, и организовывает их хранение в массиве. после этого массив пересор- тировывается по закону: первый элемент меняется с последним

Информатика

Ответы

Guskov
//реальные числа - странное определение чисел вещественного типа
//Pascal ABC.NET v3.0 сборка 1111

Var
  ar:array[1..10] of real;
 i:integer;
 k:real;
begin
 writeln('Array:');
  for i:=1 to 10 do
   readln(ar[i]);
  k:=ar[1];
  ar[1]:=ar[10];
  ar[10]:=k;
 writeln('Final array:');
 for i:=1 to 10 do
 write(ar[i]:4);
end.

Пример ввода:
1
2
..
10
Пример вывода:
Final array:
  10   2   3   4   5   6   7   8   9   1
Timurr007

1. 1v1=1 ,  1∧0=0 ,  ¬0=1

2. ¬А=1, ВvС=0, Д∧С=1

Объяснение:

1

AvВ, если А = 1, В = 1           1v1=1

A ∧ B, если A = 1, B = 0        1∧0=0

¬ А, если А= 0                      ¬0=1

2.     1. инверсия – это логическое отрицание, в данном случае высказывание А не истинно, значит не(не истина)=истинна

2. Дизъюнкция – логическое сложение будет истинным тогда, когда хотя бы одно исходное высказывание истинно, так как В-ложь и С ложь, то ВvС=0

3. Конъюнкция – логическое умножение будет истинным тогда, когда оба исходных выражения истинны. Т.к. Д и С истинны, то и результат истина, т.е. =1

zotcet7

1. 1v1=1 ,  1∧0=0 ,  ¬0=1

2. ¬А=1, ВvС=0, Д∧С=1

Объяснение:

1

AvВ, если А = 1, В = 1           1v1=1

A ∧ B, если A = 1, B = 0        1∧0=0

¬ А, если А= 0                      ¬0=1

2.     1. инверсия – это логическое отрицание, в данном случае высказывание А не истинно, значит не(не истина)=истинна

2. Дизъюнкция – логическое сложение будет истинным тогда, когда хотя бы одно исходное высказывание истинно, так как В-ложь и С ложь, то ВvС=0

3. Конъюнкция – логическое умножение будет истинным тогда, когда оба исходных выражения истинны. Т.к. Д и С истинны, то и результат истина, т.е. =1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит с клавиатуры 10 реальных чисел, и организовывает их хранение в массиве. после этого массив пересор- тировывается по закону: первый элемент меняется с последним
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

starabanov
самир1078
lavr74
partners
nsn-2012
Бегун-Марина
Igor1406
dima-pashkovec
Джулия
terma-msk1
anastasiaevent4
Vrpeshka
ПетросовичЗаславский
hristos1212
ynikolaev2657