Mashkov-Daniil1764
?>

Составить программу, находящую среднее арифметическое любых пяти чисел. в цикле для, пока, до

Информатика

Ответы

Pervosha
Var
  i:integer;
  a,b:real;
Begin
  for i:= 1 to 5 do Begin
    a:=random(50);
    write(a,' ');
    b:=b+a;
  End;
  Writeln;
  write('Их средн арифм = ',b/5);
End.
Bezzubova_Stepanov1355

1.

program z1;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

write ('S = ');

for i:=1 to n do

begin

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1)

end;

write (S)

end.

2.

program z2;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

i:=1;

write ('S = ');

repeat

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1);

i:=i+1

until i>n;

write (S)

end.

3.

program z3;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

i:=1;

write ('S = ');

while i<=n do

begin

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1);

i:=i+1  

end;

write (S)

end.

Объяснение:

картинки


Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд
Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд
Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд
elenaftdv7
Алфавит- символы для записи конструкций языка программирования (из каких знаков составляются конструкции языка). Алфавит языка состоит из букв, цифр и лексем.
Лексема - это наименьшая единица языка имеющая самостоятельный смысл. К лексемам относятся:
спецсимволы (==, !=, ++, =, >, < и т.д.);
ключевые слова (main, switch, if, while и т.д.).
Синтаксис
Правила записи конструкций языка (какие конструкции принадлежат языку).
Семантика
Смысл конструкций языка программирования (как конструкции обрабатываются компьютером).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, находящую среднее арифметическое любых пяти чисел. в цикле для, пока, до
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oserdyuk41
kisuhakisa
mariashapar
vyborovvs
Logukate
tarja4140
Ilin1022
elaginaelena70
ella-rudenko
zhunina71807
Лифанов_Ольга
Антон
Владислав893
mzubenko6
yuda12