Belov
?>

Напишите программу которая считывает 5 целых чисел определяет и печатает наибольшее и наименьшее из них

Информатика

Ответы

Vera_Shuklin
Var a1,a2,a3,a4,a5,max: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1>a2) then max:= a1else max:=a2;
if (a2>a3) then max:=a2else max:=a3;
if (a3>a4) then max:=a3else max:=a4;
if (a4>a5) then max:=a4else max:=a5; 
  end;
writeln (max);
end. 
Аналогично с минимальным числом.
var a1,a2,a3,a4,a5,min: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1<a2) then min:= a1else min:=a2;
if (a2<a3) then min:=a2else min:=a3;
if (a3<a4) then min:=a3else min:=a4;
if (a4<a5) then min:=a4else min:=a5; 
  end;
writeln (min);
end.  
Можно так же решить с массива, если нужно пишите.
Rjkjneirbyf555

ответ:Пример 1. Составить алгоритм запуска программы Paint в ОС Windows 7.

Вспомним из курса информатики 5 класса порядок действий для запуска программы Paint.

Войти в меню «Пуск».

Войти в пункт «Все программы».

Войти в пункт «Стандартные».

Выбрать программу «Paint».

Данный алгоритм в виде блок-схемы имеет следующий вид:

 

Рис. 1. Блок-схема к примеру 1.

 

Составление алгоритмов с ветвлениями

Рассмотрим пример на составление алгоритмов с ветвлениями.

Пример 2. Составьте алгоритм для перехода дороги на светофоре.

Рис. 2. Светофор (Источник).

Возможны следующие ситуации: в тот момент, когда мы подошли к дороге горел красный или зелёный свет. Если горел зелёный свет, то можно переходить дорогу. Если же горел красный свет, то необходимо дождаться зелёного – и уже тогда переходить дорогу.

Таким образом, алгоритм имеет следующий вид:

Подойти к светофору.

Посмотреть на его свет.

Если горит зелёный, то перейти дорогу.

Если горит красный, то подождать, пока загорится зелёный, и уже тогда перейти дорогу.

Блок-схема данного алгоритма имеет вид:

Рис. 3. Блок-схема к примеру 2.

 

Составление циклических алгоритмов

Рассмотрим пример на составление циклического алгоритма. Мы уже несколько раз обсуждали перевод чисел из десятичной системы в двоичную. Теперь пришло время чётко сформулировать этот алгоритм.

Напомним, что его принцип состоит в делении числа на 2 и записей остатков, получающихся при делении.

Пример 3. Составить алгоритм перевода чисел из десятичной системы в двоичную.

То есть, алгоритм будет выглядеть так:

Если число равно 0 или 1, то это и будет его двоичное представление.

Если число больше 1, то мы делим его на 2.

Полученный остаток от деления записываем в последний разряд двоичного представления числа.

Если полученное частное равно 1, то его дописываем в первый разряд двоичного представления числа и прекращаем вычисления.

Если же полученное частное больше 1, то мы заменяем исходное число на него и возвращаемся в пункт 2).

Объяснение:

household193

1. Например: смотреть д/з, играть в игры, смотреть видео уроки и т.д.

2. Учителя могут искать тесты/контрольные работы что-бы их провести в классе, так же они могут смотреть информацию для какого либо урока. Старшие могут смотреть что то по работе или то что нужно им сделать для своего ребёнка например-призентацию и т.д.

3. По интернету можно смотреть видео уроки, д/з, информацию для доклада/сообщения в школу.

4. Иногда как, бывает хорошо, а бывает плохо, одна причина почему очень неприятно-мошеники в интернете которые всех обманывают.

Вот мой ответ удачи

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая считывает 5 целых чисел определяет и печатает наибольшее и наименьшее из них
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olechka197835
Amulenkov
antoska391
masha812
AndreiAstakhva1442
Владимир-Денисович1080
Aleksandrovna Kolesnik1764
с информатикой(8 класс РЭШ)
vvb1383
mashumi2170
aza2103
pashyanaram
Anna-Miron
dianakryukova00
Джулия
kisa-luba