Валиахметова
?>

надоо. написать программу, которая вычисляет среднее арифметическое трёх чисел, если известно, что первое число больше второго в 3 раза, второе меньше третьего на 16 второе число вводиться с клавиатуры.

Информатика

Ответы

skachmin
Var a, b, c, s: real;
begin
readln(b);
a:=b*3;
c:=b+16;
s:=(a+b+c)/3;
writeln(s);
end.
firsova5911

ответ:

отдел +;

использует приём из "", вывод из "";

пер

  n, сумма, сч, скор, макс: цел;

указ

  сумма : = 0;

  макс : = 0;

  вывод.цепь("введите число автомобилей: ");

  n : = приём.число();

  если n < 1 и n > 30 то вывод.цепь("^ошибка.") иначе

    вывод.цепь("^введите скорости: ^");

    от сч : = 1 до n вып

      скор : = приём.число();

      если n < 1 и n > 300 то вывод.цепь("^ошибка."); стоп(0) кон;

      увеличить(сумма, скор);

      если скор > макс то макс : = скор кон;

      вывод.цепь(" ")

    кон

  кон;

  вывод.чвещ("^средняя скорость: %.1f.^", сумма / n, 0, 0, 0);

  если макс > = 60 то вывод.цепь("yes") иначе вывод.цепь("no") кон

кон .

объяснение:

toxicfish
Уберите char. После begin не ставится точка с запятой. В Else не нужна точка с запятой, если там один оператор. После of точка с запятой не ставится. В перечне значений case не нужно =. Вывод по ходу программы не очень удобный. В последнем выводе выводите переменные просто как буквы, это ошибка. Вот, исправил основные ошибки. program abc; var a,b:integer; begin writeln('Введите количество десятков лет'); readln(a); case a of 1:write('десять'); 2:write('двадцать'); 3:write('тридцать'); 4:write('сорок'); 5:write('пятьдесят'); 6:write('шестьдесят'); 7:write('семьдесят'); 8:write('восемьдесят'); 9:write('девяносто'); Else Write('Число введено неверно') end; writeln('Введите количество едениц лет'); readln(b); case b of 1:write('один'); 2:write('два'); 3:write('три'); 4:write('четыре'); 5:write('пять'); 6:write('шесть'); 7:write('семь'); 8:write('восемь'); 9:write('девять'); Else write('Число введено') end; write(a, b, ' лет'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

надоо. написать программу, которая вычисляет среднее арифметическое трёх чисел, если известно, что первое число больше второго в 3 раза, второе меньше третьего на 16 второе число вводиться с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

druzhbamagazin2457
vladimir686
nuralievelsh
Dom540703174
frolevgevg6420
АндреевичЮлия
iskypka
ohussyev
kriapex
zhmulyov-denis8
seregina19706867
vladburakoff5
savva-vika
Vera-zero281
goodsled