Vorotko814
?>

ниже на пяти языках ( в pascal) записан алгоритм. получив на вход число x, этот алгоритм печатает два числа a и b. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6 , а потом 18.

Информатика

Ответы

falileevas

ответ: 100288

объяснение:

если интеренсно , как я решил , то вот

#include

int main()

{

unsigned long a = 0, b = 0,x;

for (unsigned long y = 1; y < 2; y++)

{

x=y;

a=0;

b=0;

while (x > 0)

{

a++;

if (x % 2 == 0)

b = b + x % 10;

x = x / 10;

};

if(a==6 & & b==18)

{std: : cout < < y< < ")" < < a < < " " < < b;

exit(0);

}

};

}

Pavlushina-Novikova

program z1;
var
i,j,m,k,z,x,l:integer;
begin
readln(m);
for i:=0 to m do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*4;
x:=x-1;
end; end;
if ((z<m) and (z*4>m)) then writeln(i);
if z=m then writeln(i-1);
end;
end.

 

program z2;
var
i,j,n,k,z,x,l:integer;
begin
readln(n);
for i:=0 to n do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*2;
x:=x-1;
end; end;
if ((z>n) and (z/2<n)) then writeln(i);
if z=n then writeln(i+1);
end;
end.

 

program z3;
var
i,j,n,k,z,x,s:integer;
begin
readln(n); s:=0;
for i:=1 to n do begin z:=1;
for j:=i to 2*i do
z:=z*j;
s:=s+z; end;
writeln(s);
end.

 

время 2 ночи 

...думаю пора спать ) 

missbuhgalter2013
1 Глобальная компьютерная сеть – это:
Г совокупность локальных сетей и компьютеров, расположенных на больших расстояниях и соединенных с каналов связи в единую систему.

2 Локальные компьютерные сети как средство общения используются только для:
г) осуществления обмена данными между несколькими пользователями, организации доступа к устройствам вывода и к общим информационным ресурсам местного значения.

3 Телеконференция – это:
в) система обмена информацией между абонентами компьютерной сети;

4 Компьютер, подключенный к Интернету, обязательно имеет:
а) IP-адрес;

5 Гипертекст – это:
б) структурированный текст, в котором могут осуществляться переходы по выделенным меткам;

6 Серверы Интернет, содержащие файловые архивы, позволяют
а) скачивать необходимые файлы;

7 Россия имеет следующий домен верхнего уровня в Интернете
б) ru;

8 Транспортный протокол (TCP) обеспечивает
а) разбиение файлов на IP-пакеты в процессе передачи и сборку файлов в процессе получения; (в учебнике написано так, но это неправда, конечно. TCP и IP - разные протоколы, TCP не требует наличия каких-то "IP-пакетов")

9 HTML (Hyper Text Markup Language) является:
а) средством создания Web-страниц;

10 Задан адрес электронной почты в сети Internet [email protected] Каково имя владельца этого электронного адреса?
б) user_name; (то, что стоит до собачки @ - имя, после - домен)

11 Модем – это:
г) техническое устройство.

12 Браузеры (например, Microsoft Internet Explorer) являются:
г) средством просмотра Web-страниц.

13 Почтовый ящик абонента электронной почты представляет собой:
б) часть памяти на жестком диске почтового сервера, отведенную для пользователя;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ниже на пяти языках ( в pascal) записан алгоритм. получив на вход число x, этот алгоритм печатает два числа a и b. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6 , а потом 18.
Ваше имя (никнейм)*
Email*
Комментарий*