orantus3
?>

Напишите программу в паскаль авс , которая по значению числа выводит его название(числа от 1 до 9

Информатика

Ответы

fudan
Var i : integer;
begin
write("Введите число: ");
readln (i);
select i of
case 1 : writeln("Один");
case 2 : writeln("Два");
case 3 : writeln("Три");
case 4 : writeln("Четыре");
case 5 : writeln("Пять");
case 6 : writeln("Шесть");
case 7 : writeln("Семь");
case 8 : writeln("Восемь');
case 9 : writeln("Девять");
case 0 : writeln("Ноль");
end;
end.
yocrew13

Джон и Смит

Объяснение:

1. Допустим дважды правду сказал Джон. Тогда Браун невиновен, а Смит - виновен. Смит, утверждая, что он невиновен, солгал. Он также солгал, обвиняя Брауна. Следовательно Браун один раз сказал правду. Проверим. Браун сказал, что это не он и не Джон, т.е. сказал правду дважды, что противоречит нашему выводу. Следовательно, Джон не мог дважды сказать правду.

2. Допустим, дважды правду сказал Браун. Тогда он невиновен, и Джон невиновен, следовательно, виновен Смит. Смит заявил что он невиновен и солгал. Он также обвинил Брауна и солгал еще раз. Значит, один раз правду сказал Браун. Эту версию мы проверяли выше, следовательно исходное допущение неверно.

3. Методом исключения получаем, что дважды правду сказал Смит. Он невиновен, а виновен Браун. Браун, говоря что он невиновен солгал, а его оправдание Джона - правда. Получается, что дважды солгал Джон. Он оправдал Брауна - и это ложь. Также ложно его обвинение Смита.

Противоречий нет, следовательно невиновны Джон и Смит

Терентьева
Запишем высказывания Джона, Брауна и Смита в виде таблице, где o - это предположительный вор со слов одного из участников процесса, а x - невиновный.

         Д       Б        С
Д                x         o
Б       x       x
С                o         x

Рассмотрим варианты:
1. Джон сказал правду, тогда Смит - вор, тогда имеем
    Джон 2 раза сказал правду
    Браун 2 раза сказал правду
    Смит 2 раза соврал. 
Этот вариант не подходит под условие задачи.

2. Браун сказал правду, тогда очевидно снова Смит - вор, тогда
    Джон 2 раза сказал правду
    Браун 2 раза сказал правду
    Смит 2 раза соврал. 
Этот вариант тоже не подходит. 

3. Смит сказал правду, тогда Браун - вор, тогда
    Джон 2 раза соврал
    Браун 1 раз соврал, один раз сказал правду.
    Смит 2 раза сказал правду. 
Вариант подходит.

Значит 
Браун - вор и не может быть оправдан.
Джон - оболгал невиновного человека (Смита) и должен быть наказан за это.
Смит - не врал и не крал. Следовательно Смит должен быть оправдан.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскаль авс , которая по значению числа выводит его название(числа от 1 до 9
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alsergus7811
Геннадьевна Вета560
Как научиться программировать
lion13
Salnikov1730
алексей-Ветошкин
Почему 2 в 14 степине равен 16384
MikhailovichVitalevich1393
Шарабанов
eduard495
sjmurko
dovgash2
Khlistova1488
Irina Svetlana
langprint
КузменковаЖигулин
a800000
▲