Объяснение:
Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.
Поделитесь своими знаниями, ответьте на вопрос:
Измените, чтобы значения размеров занимаемого поля вводились с клавиатуры. скомпилируйте. сохраните. program diagram; uses crt, graphabc; const a: array[1..5] of integer = (47, 63, 22, 27, 12); b: array[1..5] of string = ('рожь', 'пшеница', 'овес', 'ячмень', 'гречиха'); var u, u0, s, i: integer; begin setwindowsize(600, 600); s: =0; u0: =0; for i: =1 to 5 do s: =s+a[i]; //вычисление суммарной площади for i: =1 to 5 do begin writeln(b[i], ' ', a[i], ' га ', round(100*a[i]/s), ' %'); setbrushcolor(rgb(random(255), random(255), random(; u: =u0+round(a[i]*360/s); //вычисление конечного угла сектора pie(220, 240, 140, u0, u); //рисование сектора u0: =u; //новое значение начального угла следующего сектора end; end.
Ввод массива с клавиатуры выглядит вот так:
var
razmer, i2: Integer
WriteLn (‘Введите размер массива’);
ReadLn (razmer);
For i2:=1 to razmer do
Begin
WriteLn (i2,’ ’);
ReadLn (A[i2]);
Массив В вводится так же...